powered by Jive Software

New (L)user trying to make sense of it all

ok, i know nothing, and i know this. but i know that i need to get openfire running and i hope someone can help me.

I installed openfire on my centos box with the latest RPM. I had it working with the built in JAVA since my server does not have JAVA on it. (And at this point in time installing it is WAAAAY beyond me)

Problem is that i had it running only when i manually ran ./openfire.sh , but as soon as i terminated the session, openfire would close as well.

So i read on the install instructions about something call redhat-postinstall.sh , which is not in the RPM, but in the tar.gz , so (not so) clever chap I am, i extract it from the tar.gz into /opt/openfire/bin/extra and ran it. then things went awry.

When i run ./openfire.sh i get a whole screen of insults thrown at me by the script mostly relating to java.

is there any way for me to completely remove openfire and all the changes it made to my system, and start from scratch.

thanks in advance

or you can just laugh at me


Don’'t be so hard on yourself. If you installed the most recent RPM, an init script should have been installed in /etc/init.d/ such that you can now control openfire via init.

service openfire start

for example, can correctly start it


It starts, but when i go onto the web interface, i get up to the page

and when i click continue

this happens

(dramatic music)




Caused by:


at org.jivesoftware.util.JiveGlobals.deleteXMLProperty(JiveGlobals.java:492)

at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(setup_002dprofile_002dsettings_jsp.java:75)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:491)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1074)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1065)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:185)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:689)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:391)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:146)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:285)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:457)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:765 )

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:627)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:209)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:357)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:329)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:475)

Powered by Jetty://


My guess is that you now have permissions issues. If you are starting fresh, remove the old rpm, blow out /opt/wildfire, install the rpm again and then start it with the init script.

Or else see what the file ownerships are like in /opt/wildfire


How do i get past the message that says package openfire-3.3.1-1 is already installed.

step by step if possible

“rpm -e openfire” should remove it, then you should be able to reinstall it.

the rpm -e openfire worked, but when i try to run

rpm -ivh openfire… i get the error

installing package openfire-3.3.1-1 needs 47MB on the / filesystem

wierd, or maybe not i dont know

thanks for your help i really appreciate it because im still learning

That message indicates that you do not have enough space in your filesystem to do the installation.

The command df -h will show you all your filesystems and the amount of space free. You will probably find that the root file system ( / ) is almost completely full.

it says i still have 77mb on /

The way the server is set up the / partition is only 244mb

is there anything generic that is safe for me to delete, although 77 seems enough unless the system only allows so much % to be used or something

77 mb free is a very small amount for your root ( / ) partition. Even if you could do the installation, you would be left with only 4 mb.

Two options

  1. make a new disk partition /opt

  2. Put the install on another partition with space by using a symbolic link.

#2 is the easiest. Here is what to do

do the command df -h again and find a partition that has lots of space ( 1GB or more would be good. Lets assume you have lots of free space on /var. If you use a different partition, change the commands below to the new partition). You will have to do these commands as root.

mkdir /var/openfire

ln -s /var/openfire /opt/openfire

Now try the install again.

did it, and it installed

when i connect to the server i get




Powered by Jetty://

i think in my infinite stupidity i managed to thourougly mess up the installation

rebooted the server and it now works, thanks

Hi, I had the same problem.

I figurate that a openfire daemon start up when I turn on the computer(Fedora C6), is that the reason that when i installed openfire i didn’'t have this problem.

So in the command line write:

#ps aux | grep openfire

see what is the PID and kill that procces.

#kill PID

then start openfire from the script:

  1. cd /opt/openfire/bin

  2. ./openfire.sh start

That is all, and it works.

Please, I’‘m newbe on linux, so if someone knows how to stop that the openfire daemon start up when the computer turn on, make me know. (sorry by my english, i’'m latinamerican).

Att: Laura Zapata Aspiazu.