powered by Jive Software

New openfire administrator

Problem 1) I’m trying to gain access to the administrator console. I’m a new admin to the system so i don’t know what this was or if its ever been changed from the default. I’ve tried to change the xml tags in the openfire.xml file. addint the adding the tags with appropriate data. I also changed the from true to false. In either case this didnt work to help me logon. Here is the pastebin of the file http://pastebin.com/amLCXWqJ

Problem 2) The reason i’m trying to access the console is to help me troubleshoot another connectivity problem i’m having. I have openfire 3.7.0 installed on centos release 5.6 (final). This server sits behind a comcast gateway, and a router. The firewall on the comcast router is shutoff, the internal router uses port forwarding. I’m forwarding ports: 5222 - 5223, 7777, 9090 to the openfire server.

When I try to connect spark to the server from within the network, i have to use the lan server address. When I try connecting using the public address of the router, i get the error “Can’t connect to server: invalid name or server not reachable”.

There are several branch offices that can connect to the server from outside the gateway using the public ip. Also when I connect from my home I can connect using the public ip. However there are two branch offices that cannot connect and they get the same error message “Can’t connect to server: invalid name or server not reachable”.

I don’t believe its an issue with openfire or the mysql database as I can connect with any valid usernames while the network conditions i explained above are true. It seems to be somekind of routing issue. I have swapped out the internal router and I’ve power cycled the comcase gateway and even power cycled the two switches.

This had not been a problem and recently started happening but I 'm not sure what triggerd the problem. Please help with any suggestions.

When you change setup tag, you have to restart Openfire and then open Admin Console ural and it will show setup process then. Then you will be able to set a new password.