powered by Jive Software

New users not importing correctly from LDAP

We are using Open fire 3.8.1 with Spark clients.

We also have LDAP (Active Directory) setup, and all our users and groups have been imported.

However we have an issue… ** Now when i create a new user in AD and put them in the proper groups, they do not come into OpenFire server as they should…**

What we are seeing is this: cn=pitttest,ou=sales,ou=pit,dc=relia,dc=com@nyrfcchat01__* __

There is this message at the bottom of the page…* Note: Remote users or entities should accept presence subscriptions automatically.

I read some other discussions with this issue, but mine is a bit different. There are no special characters in the OU, and things were were as they should have up to this point.**
**

This is preventing this new account to log into the client.

**
**

Nothing has changed, as i am the only one that manages this OpenFire server.

Any thoughts? Keep in mind this is only affecting newly created users.

Thanks

-Evan

I’m having the same issue on 3.8.2. I created a new group, added 7 members, and I see 5 of them when I log in. I’ve tried removing the other 2 from the groups, then re-adding them, but nothing has helped. I tried clearing the cache, restarting the service, even rebooting the server.

Check to see that the users have an email address listed. I don’t remember exactly, but i think that was the issue.

I just checked. They both have emails listed.

OK, I figured it out. In AD, under the Security tab, the openfire admin user account didn’t have ‘read’ access. They are visible now.