powered by Jive Software

Newbie: Instalation problem : Msn gateway!

Hi, i’‘ve instaled the jive server in my LAN on my Suse 10.RC1 on 10.76.46.134. It’'s a local address i know, and it works fine.

I’'m trying to install PyMSNt under this server. I can see it in “Jive Messenger Admin Console > Component Sessions” fine.

I’'ve made an entry in /etc/hosts to simulate msn.miguelcarvalho.com and configured pyMSNt with (most relevant file part):

And i can’‘t get at least the transport to be announced in services, like i’'ve confirmed with “Jabber Transport Registration” form and kopete.

  • it’'s necessary to add some configuration to jive-messenger.xml?

  • it’'s it possible to announce the service locally?

  • do you need a public ip address for msn or other protocols registration, right?

  • Anything i’'m doing wrong?

Txs In Advance,

maik

I’'ve made an entry in /etc/hosts to simulate

msn.miguelcarvalho.com and configured pyMSNt with

(most relevant file part):

what entry?

i think in config should be:

what’'s the hostname of machine?

The entry is

10.76.46.134 msn.miguelcarvalho.com

being 10.76.46.134 my lan address.

The host name it’'s Horacio. But for the service to make a real connection to msn i would need an public ip address or not?

txs

mk

The entry is

10.76.46.134 msn.miguelcarvalho.com

I think this line in hosts of a PC that does have such address doesnt make sense. But i’'m not a linux or network guru. Such line must be in all others machines hosts for them to be able to see your machine as msn.miguelcarvalho.com or whatever. But if a number of other machines is too big this is not a good solution.

being 10.76.46.134 my lan address.

The host name it’'s Horacio. But for the service to

make a real connection to msn i would need an public

ip address or not?

try this:

well, i was testing only PyICQ at my local Win2000Pro machine. And gateway was working fine without external IP. I’'m in LAN too.

Mark,

  • it’'s necessary to add some configuration to jive-messenger.xml?

No

  • it’'s it possible to announce the service locally?

What do you mean by announce?

  • do you need a public ip address for msn or other protocols registration, right?

No

  • Anything i’'m doing wrong?

Making it more complicated then it is???

As long as the DNS on your lan can resolve msn.miguelcarvalho.com to the right machine, you should be good to go.

The bigest thing people get hung up on is thinking that PyMSN is a server that MSN is happy to talk to, when it is really a “fake” msn client that pretends to be you and relays your chats to the MSN servers on your behalf.

There is no need to DNS setup on the public side pointing msn.miguelcarvalho.com to your computer.

Hope this helps.

Peter

Followed both of yours suggestions… Changed hosts file to “msn.Horacio” and “” with no results. I even changed hosts entry to 127.0.0.1.

I’‘m not using DNS, it’'s it not possible without it? off course on win it is, but in linux?

Best Regards,

mk

PS:

Jabber transport registration errors:

"Could not find a MSN Transport on your server. Please contact your server administrator.

There was an error registering you with the MSN Gateway. Please try again later."

Hi behem0t,

Are you sure you configured your jive server to accept components on

port 5347 /b

with secret fake_secret[/b]

See (in jive webadmin)

Server Settings

-> External Components

->Service Enabled

  • Enabled

  • Port: 5347

  • Default shared secret: fake_secret

And added ‘‘msn’’ to your whitelist

Server Settings

-> External Components

-> Allowed to Connect

  • Whitelist

  • Subdomain: msn

  • shared secret: fake_secret

If you installed PyMSNT correctly you should be able to see the service in the

webadmin under

-> Active Sessions

-> Component Sessions

even if msn.miguelcarvalho.com is not resolving to your server’'s ip-address

since the component is connecting to your local-ip 127.0.0.1

Regards Gepatto

And added ‘‘msn’’ to your whitelist

Server Settings

-> External Components

-> Allowed to Connect

  • Whitelist

  • Subdomain: msn

  • shared secret: fake_secret

It souldn’‘t be necessary cause i’‘m using the Default shared key. Anyway i’‘ve tried that and it still don’'t works.

"If you installed PyMSNT correctly you should be able to see the service in the

webadmin under

-> Active Sessions

-> Component Sessions"

I Do see the component since the time i’'ve installed pyMsnT.

Txs,

b0t