powered by Jive Software

Newbie with a client authentication problem

I have installed the Jive messenger server and everything seemed to be going smoothly. Even edited the ldap portion of the config file, and it has successfully pulled over the data from AD. I can log into the admin console from my computer without any issues, and all the expected users are there.

Here’'s the problem: I cannot get the client software to successfully create a session on the jive server. It gets stuck at the authenticating part. I have tried the latest versions of both Trillian (pro) and Gaim with no luck.

I think the problem lies in the servername… I named it CTS-IM (which is not a host or computer on the network), then created an Alias (cname) on the dns server to point CTS-IM to the actual box that the jive server is located on.

Below, I have copied and pasted the logs from both the Gaim client and the Jive server.

In Gaim, I opened the debugger window, and this is the log:

(12:09:08) account: Connecting to account 010D0368. gc = 01582BC8

(12:09:08) connection: Connecting. gc = 01582BC8

(12:09:08) connection: Calling serv_login

(12:09:08) server: gaim 1.5.0 logging in nbrown@CTS-IM.trainright.com/Gaim using Jabber

(12:09:08) dns: DNS Lookup for: CTS-IM.trainright.com

(12:09:09) proxy: Connecting to CTS-IM.trainright.com:5222 with no proxy

(12:09:09) proxy: Connect would have blocked.

(12:09:09) proxy: Connected.

(12:09:09) jabber: Sending:

2005.10.11 12:09:09 OS - Trying to connect to trainright.com:5269

I think that the Jive server is confused because it is looking for a host to connect to, but CTS-IM is not a host… Is there anyway to bypass this? I would rather not have to give it the IP name (I have been able to get the clients to connect successfully when the Jive servername is the IP address of the computer). Especially since I can navigate to and open the admin console from other computers without having to use the IP.

The only changes I have made to the Jive default configuration is to edit the ldap portion of the config file… everything else is still default.

Any suggestions or feedback are greatly appreciated.

Thanks in advance,

nicci

Does anyone have any ideas? I still cannot get this to work… I am using Jive Messenger 2.2.2…

Any help or advice is greatly appreciated.

This is a stab in the dark. under the server properties, what server name are you using?

CTS-IM or CTS-IM.trainright.com?

If it is set for the first, try the second one. I had a similar issue the other day with a new install of my server where i was getting near the same error message on the client and then realized that the clients were all trying to connect to “jabber…org”

As soon as i changed the property on the server page, everything worked as normal.

I doublechecked everything that I could find (including the server name), and all is set to CTS-IM.trainright.com

Including the entry in dns, and the server name in the client. The clients are still stuck at authenticating…

Is there something else that I am missing?

Thanks,

-Nicci

If you don’'t mind, what does your ldap modification look like?

I was looking at the XMPP core and the error in your Jive log:

2005.10.11 12:09:09 RS - Received dialback key from host: CTS-IM.trainright.com to: cts-im.trainright.com

2005.10.11 12:09:09 RS - Error, hostname not recognized: cts-im.trainright.com[/b]

could be from the Authenticating Host portion of the in the dialback authentication. I could be completely off track (protocol specs confuse me), but if all the machines in question (clients and server) can properly resolve cts-im.trainright.com[/b], it would seem that it’'s something beyond name resolution.

Hey nicci,

Could you try using all lower case letters in the server name? Let us know if the problem persists.

Regards,

– Gato

That just seemed to obvious, Dom. I wasn’‘t sure if name resolution was case sensitive or not. Didn’‘t think it was, if that’'s all it turns out to be, that will be a good one to remember.

Gato,

AWESOME! That did it… just changed it to lowercase in the dns on the PDC, renamed the server to lowercase in the admin console, and updated the setting in the client.

Thank you so much!!

-Nicci