powered by Jive Software

No ''Dial'' button

Hello.

Can’'t seem to get a ‘‘Dial’’ button in my Spark slient.

  • Asterisk@Home latest version.

  • Wildfire loaded on same server as Asterisk, latest version.

  • Spark on a Windows XP workstation, latest Spark version.

  • Asterisk-IM plugin, latest version.

WildFire starts and runs fine, and it sees the Asterisk-IM plugin. It also sees my SIP channels fine. Spark starts and runs fine, and has all the IM functions, but no ‘‘Dial’’ button.

It seems that although each program is running, Asterisk-IM is not talking with Asterisk.

Three questions:

  • Is there a way to verify the connection between AsteriskIM and the Asterisk server ?

  • Can there be a problem with having both Asterisk and Wildfire on the same server ?

  • I’'m using an IP address in Spark. I tried the FQDN for the server but it never connected. Spark connects using the IP address, but can this be a problem ?

Many thanks !

P James

Hi,

did you configure the “Phone Mapping”? Afaik you can not do this as long as the plugin is not connected to asterisk. The error.log file should contain some errors if the connection fails. I experienced some problems and had to restart Wildfire before the connection to asterisk could be established/used.

Do you see the “on the phone” message while you are using your phone or is the dial button the only missing thing?

LG

Hello LG.

Yes, I was able to do phone mapping to my SIP devices in the Wildfire Admin Console. Everything seems to have connected properly.

I don’‘t see the ‘‘on the phone’’ status when I am using the phone, nor do I see the ‘‘Dial’’ button. Makes me think I’'m not connected properly.

I’'ll restart Wildfire as you suggest, and examine the error log for problems.

Thanks for your response !

Paul James

Same problem here. Spark 1.1.1 Wildfire 2.5.0 running on Windows 2003 Server, Asterisk@Home 2.5, Servers are communicating fine. No dial button or on phone indication in Spark, other than that all is great. Andrew mentions Spark 1.1.0 works, but I see no way to download previous versions.

Thanks

Chip

Try to use a FQDN (Full Qualified Domain Name) of the Wildfire server (not the IP address). Put this FQDN name to your Asterisk server as a hostname of the linux machine, if you’'ve installed Wildfire in the same machine as asterisk/*@home. Use a FQDN name of asterisk when you configure Asterisk-im. Be sure to use the correct username/password at the window of Asterisk-im configuration;

I found no dial button then i went back and checked all my settings and found that the username for the im account is case senseative so i had to make it all lowercase in the asterisk-im module, hope this helps

Ikasneci, I’'m not sure I understand. FQDN of Wildfire (Win 2003 Server) is “server01.OVIS1.local” Our AAH server is the default AAH “Asterisk1.local”

Asterisk-IM settings[/b]

  • Enabled: x Yes No

  • Server: 10.0.0.151 (If I put “Asterisk1.local” I can’'t connect to manager or phone mapping)[/i]

Port: 5038

  • Username: Wildfire

  • Password: 1234

Pool Size: 5

Asterisk Context:

Default Caller ID:

Dial Command Variables:

In manager_custom.conf I have:[/b]

secret=1234

permit=10.0.0.111/255.255.255.0

read = system,call,log,verbose,command,agent,user

write = system,call,log,verbose,command,agent,user

Never mind, seems I got it working with IP address, I’‘m not sure how though…Still seems I have a bug with calls, but can’'t continue to test just now.

Thanks for the great software!!!

Message was edited by: ChipW

Message was edited by: ChipW