powered by Jive Software

No Dial Option in Spark

i cant see any dial options in spark. can any one pls guide me in this

Hi Muhammad,

did you set up Asterisk and did you install and configure the plugin as described here?

Do you see the “On the phone” status?

Maybe you can post some more information about your setup, it’'s very hard to guess what could be the problem. You may also search for some other no dial button threads.

LG

This is the scenario the i am using

  1. I have asterisk box configured on machine with extentions e.g. 888 and 999

  2. I have installed Wildfire server on another machine with Asterisk-IM plugin

  3. Asterisk-IM plugin and Asterisk are communicating with each other and also Did Phone mapping on Asterisk-IM plugin.

4)when i sign in on spark i can see on the phone status with a small phone icon on left side of online usernames.

Now the problems.

1)i dont see any option in spark to dial the user

2)when i try to call from x-lite phone on the extension on which spark is registered i dont see any notification for incoming call.

Please gimme a detailed guide step-by-step.as how can i accomplish the task.

as this will not only help me but many others will be helped too.

Thanx

The same Problem here… (and sorry for my terrible english )

Asterisk runs on a Open Suse10 - Server, WIldfire on the same Machine.

Sparl runs on Windows XP and a Notebook with Open Suse10.

On the phone we can see the online status, but we can’'t see any call button…

Just a question: What means this entry in the readme file?

<Client API

< The client API first requires that the Asterisk-IM server plugin is installed. To initialize the <client do the following:

<XMPPConnection conn = new XMPPConnection(“myserver.foo.com”, “user”, “password”);

< PhoneClient client = new PhoneClient(conn);

< Note that the XMPPConnection passed in must be authenticated. If an unauthenticated <connection is passed in an exception will be thrown.

What should i do qith this information? Copy this lines in a config file?

i have the same problem… (partially)

what i mean by this?

When logging in using Spark and putting in the Wildfire IP address /bon the Server Field, the Dial Option is not showing up.

BUT

when ever I use the Wildfire server Fully Qualified Domain Name /b(e.g. asterisk1.headoffice) rather than the IP address, the Dial Option shows up.

It appears like Spark is doing a DNS query on the IP address (treating it like a FQDN) resulting to Hostname resolution error… whenever this occur, I do not see the Dial option.

Is this a BUG?

Cheers

Erick

I will look and see if I can reproduce the no Dial button issue. Logically this should only happen if the user is not mapped, the manager connection between Asterisk-IM and the pbx fails, or if the plugin did not load for some other unknown reason (ie. Database upgrade issue).

Erick,

Thanks for the info. Perhaps Spark may be the culprit.

Daniel,

The Client API portion if for if you are wanting to write a client that connects to the Asterisk-IM server. It is from the java client API.

Message was edited by: andrew

If it’'s any help I had a similar problem on my setup. The solution for me was to add:

A=B

to the Dial Command Variables: box on the admin screen. Don’‘t know why it works, presume it’‘s somthing about an empty variable, but it did work. There is another thread with more details on this. You’'ll have to restart spark after adding this.

James

Hi,

I also have this issue, but it worked fine until I upgraded my Wildfire server, asterisk-im, and Spark versions to the latest (hence I don’'t know which caused it!!)

The On the Phone status works fine, so I think asterisk-im is setup correctly, but we no longer get the Dial option in Spark, and no incoming call notifications.

Adding the A=B thing didn’'t make any difference to our setup.

Thanks,

Ben.

i had this posted on jivewire support as well… sorry

===================================

ITS ACTUALLY A DESIGN PROBLEM

if the jivewire server name settings/properties is filled using the server IP address,

AND in Spark, the same IP address is used for the Server field

YOU will see the Dial Icon

if the jivewire server name settings/properties is filled/defined using the FQDN

AND in Spark, the same FQDN is used for the Server field

YOU will see the Dial Icon

If cross paired: NO DIAL ICON

Anyone, please advise what’'s the solution to make the cross paired combination work

cheers

erick

Hoorah thanks for the info.

I fixed it in our setup by changing the servername setting in Wildfire to the fqdn that the Spark clients use rather than its real hostname.

However, the ‘‘your phone is ringing’’ box still never pops up, so not sure how to fix that.

Cheers,

Ben.