No ICQ Login possible with 1.0 Beta 6

Hi,

I’'ve upgraded to the new Version of the Gateway Plugin.

Now I can’'t login to ICQ with new ICQ-Accounts or even old ones which worked with beta 5.

I’‘ve searched the Forum but couldn’'t find any solution to this.

The exception the failure log of wildfire gives is:

2007.01.04 15:15:47 org.jivesoftware.wildfire.gateway.BaseTransport.processPacket(BaseTransport.java :387) Exception while processing packet:

java.lang.NullPointerException

at java.util.concurrent.ConcurrentHashMap.put(ConcurrentHashMap.java:846)

at org.jivesoftware.wildfire.gateway.protocols.oscar.OSCARSession.

2007.01.04 15:26:13 A new session has come online: ##jabberid##/Psi

2007.01.04 15:26:13 Created icq session for ##jabberid##/Psi as ‘’##icq-nr##’’

I hope there’'s a workaround or solution for this.

I’‘m sorry if I did something wrong, i’'ts my first post in this community.

Kind regards, Peter

I solved like it is described in this Thread :

Change the encoding property from “ISO-8852-2” to “windows-1250”, reinstall&restart the plugin and you are done. Maybe it is neccesary to restart the whole Server.

You don’‘t happen to know if you could have skipped the encoding change do you? I’'m trying to figure out if the encoding change or the reinstall of the plugin … or what … fixed this.