powered by Jive Software

No IM possible but apparently server runs smoothly

Hi,

Probably a stupid newbie problem but after mining through this forum and not finding a related thread I came to the conclusion some expert has to clue me in on this one.

I installed JiveMessenger 2.0.1 on a Windows XP PC (without SP2 but with IIS running) which is part of a corporate network. I kept all the defaults unchanged so users can register themselves freely. No hassle there. On the client side I installed the latest GAIM (1.1.0).

I registered myself and (of course) that also went without any problems. I showed up in the user list. A colleague then did the same and he also showed up in the user list. So far so good.

But when I wanted to IM him nothing happened. I checked the Session tab and I saw my session there. However, my colleague didn’'t receive the IM. Then I tried to Add him to my Buddy list and I noticed that his status stayed on Not Authorized with Subscription None (To Pending).

I also tried to IM my colleague using a screen name with and without the server name to no avail.

I used the Send Message in the Sessions page and that worked. But it’‘s no use replying to it because I can’'t receive it.

Obviously I’'m overlooking something but what?

sounds strange! Subscription state does not affect the possibility of senden messages to anybody. But some clients can be configured to not receive messages from buddies that are not on theire list. So check this first.

But you should receive the message if it is sended by the server. You can check this by listening to the xml packages that are passed between client-server-client. I do not know gaim that well, but take exodus and press f12 to see all the messages in a debug window. If you do this on both sides you may can figure out the problem yourself, otherwise send the debug stuff to this list.

good luck!

guido

Hi,

Thanks for the reply and the invaluable suggestion to use Exodus iso GAIM.

Recently our corporate network hooked up via a 1 GB link to a subsidiary location. I will not bother you with what our ICT dep. did (or didn’‘t do) but the colleague I wanted to IM was on the subloc end. He only had to change the name of the JiveMessenger server to the IP nr so that it’‘s account became Arno@172.20.1.102/Exodus. I’‘m still guessing (I was a sysadmin once but originally I’‘m a software engineer) what the problem could have been (probably something with name resolving on the subloc DC and routing to the VPN). To give you an idea of the mess on our notwork: our HQ DC’‘s still have the old names and IP’'s from the colleagues who moved. Brilliant.

So thanks again. It works like a charm now.

Hi,

I have the same problem. Adding buddy: not authorized & can not make IM.

can you give me more detail how to resolve the problem ?

regards,

nazrvl