No One can login to openfire using spark as of today. "Invalid username or password"

This is strange. And it’s getting on my nerves. No one can login, not even myself / admin. spark will not authenticate to the server. I can’t even login to the admin console to see what’s going on or tell you what version of openfire i’m running.

pertinent details…

  • server is setup as LDAP.

  • can ping hostname & ip address.

  • simply put no one can login. it’s like the LDAP has been busted.

  • Spark Ver (i don’t think this matters because everyone is having the same issue, but not everyone is necessarily on the same client version).

Is it at all possible to modify the .xml config file from the terminal when i’m having this problem?? - Maybe i can reconfigure set the config to and reconfigure?

All ideas welcome! Thanks!

The LDAP account which is associated with Openfire (the one you are logging in into Admin Console probably) is maybe locked or the password has been changed. I see it as the frequent issue in the forums when using LDAP. As i don’t use LDAP myself, can’t say what the definite solution is. Or maybe it is just a server hangup because of memory issues. Have you tried to reboot the server? Sure, you can rerun the setup by editing the openfire.xml file. Just stop the Openfire process before doing that.

1 Like

yeah, i’ve tried rebooting the server & restarting openfire and mysql. But it didn’t help.

The account binding the server via LDAP has not had any changes recently. the only thing i did change recently is a few user passwords. But ALL users now cannot login.

I’ll see if i can edit the .xml from the terminal to reset the config.

If you have some sort of text editor in the terminal then it should be easy to edit that xml file.

1 Like