powered by Jive Software

No response from server when creating muc

I am attempting to create a muc on jabber.org. Connection and login works fine, however, At the point I am calling MultiUserChat#create, I get a “no response from server” error. Did I miss something? For example, room names must follow certain conventions or something like that?

FYI: I am connecting to “jabber.org” using an account JID: "oraoraoraoraora@jabber.org"

You need to make sure you are using the conference service to create the MUC. On jabber.org it is conference.jabber.org i believe. But you will want to use service discovery to determine this.

ok, i tried it. This time it doesn’'t say “no response” but replied error (409)

Sorry, i got rid of error 409, now i get an error 404

Message was edited by: hytparadisee@hotmail.com

Thanks a lot, now i can create mucs. However, i really didn’'t know why yesterday it replied 404. I actually run my program using the same code.

Hi,

Can you paste your code over here i am also getting the same error but i am not able to solve…

Shah

Take a look at the documentation for MUC’‘s here . It’'s a big help.

I also you used to get a 404 error message, due to incorrectly naming the room. I sorted this out when i got the hostname correct, which in my case was room1@conference.it180.

So the format is

Hope this helps!