powered by Jive Software

No response from server

Have you guys experienced a lack of response from the openfire server when the server is experiencing heavy load? We’ve had a server on with hundreds of people signing in everyday (through a single ip), and we are now experiencing loss of response at log in time.

The only strange things I noticed in the logs was:

2007.10.11 08:01:19 Rate class 3 is no longer rate-limited,

according to server

More logs, this is from our(the client) side:

From debug

log:

2007.10.18

08:01:21

javax.net.ssl.SSLHandshakeException:

Initial SSL handshake failed.

at

org.apache.mina.filter.SSLFilter.messageReceived(SSLFilter.java:430)

at

org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Abs tractIoFilterChain.java:362)

at

org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilte rChain.java:54)

at

org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceived (AbstractIoFilterChain.java:800)

at

org.apache.mina.common.support.AbstractIoFilterChain$HeadFilter.messageReceived( AbstractIoFilterChain.java:617)

at

org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Abs tractIoFilterChain.java:362)

at

org.apache.mina.common.support.AbstractIoFilterChain.fireMessageReceived(Abstrac tIoFilterChain.java:353)

at

org.apache.mina.transport.socket.nio.SocketIoProcessor.read(SocketIoProcessor.ja va:246)

at

org.apache.mina.transport.socket.nio.SocketIoProcessor.process(SocketIoProcessor .java:206)

at

org.apache.mina.transport.socket.nio.SocketIoProcessor.access$500(SocketIoProces sor.java:44)

at

org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(SocketIoProces sor.java:506)

at

org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:43)

at

java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown

Source)

at

java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown

Source)

at

java.lang.Thread.run(Unknown Source)

Caused by:

javax.net.ssl.SSLException: Unrecognized SSL message, plaintext

connection?

at

com.sun.net.ssl.internal.ssl.EngineInputRecord.bytesInCompletePacket(Unknown

Source)

at

com.sun.net.ssl.internal.ssl.SSLEngineImpl.readNetRecord(Unknown

Source)

at

com.sun.net.ssl.internal.ssl.SSLEngineImpl.unwrap(Unknown

Source)

at

javax.net.ssl.SSLEngine.unwrap(Unknown Source)

at

org.apache.mina.filter.support.SSLHandler.unwrapHandshake(SSLHandler.java:666)

at

org.apache.mina.filter.support.SSLHandler.handshake(SSLHandler.java:492)

at

org.apache.mina.filter.support.SSLHandler.messageReceived(SSLHandler.java:293)

at

org.apache.mina.filter.SSLFilter.messageReceived(SSLFilter.java:398)

… 14

more

I am getting the exact same error.

Could someone please tell me a solution for this?

Thanks in advance.

  • Neha.