powered by Jive Software

No Server to Server with web.de

Hello,

i cant add web.de buddies when logged in to an openfire system.

they are named first.last@web.de but the connection server for web.de is xmpp-webde.gmx.net.

when i add them as first.last@web.de i am getting a 404 server not found error, when i add them as first.last@xmpp-webde.gmx.net i dont get any error but there is no communication possible then.

i can add s2s communication to other servers, add buddies who are on other systems, but not web.de

i suspect it has something to do with the way openfire is trying to find out what the other xmpp server is where it has to connect to?

1 Like

I think you need to create XMPP service records and use a client that supports them

See http://wiki.xmpp.org/web/SRV_Records

well, how can i add xmpp records for web.de?

i am using pidgin, about every other buddy i can add, so for example google ones.

the chat works one way, i see what my web.de buddy types, but he does not see what i type, as said, pidgin gives me a 404 error and cant authenticate the buddy.

well, i just tried tigase, with tigase s2s with web.de works out of the box, so i consider this is a bug of openfire, maybe somebody else can confirm it too pls?

and if so, create an official bug-report, so the developers can work on this, would be nice if it gets fixed.

Prior creating a bug report, some debug log from the s2s connection with web.de would be nice. Enable debug log in openfire and see if you can extract the relevant parts.

thank you for the hint about the debug log, it turned out, that the web.de certificate is not in the trusted keystore, so maybe add it for the next version of openfire.

for now i am using xmpp.server.certificate.verify = false

1 Like