"No Servers Configured" - why!? (wf 3.1.1, plugin 1.2.0beta2)

Hello!

I am really happy with WildFire and its features… simply WOW

But now I am trying to use this plugin to connect to my Asterisk and have the following problem:

When I add a new server, I enter all data and the plugin sais, Server saved OK, I can also see

on my asterisk that a connection from the manager comes in and is accepted.

BUT the server isn’'t saved…

After saving a new server, I get the green “Server saved” information but the list of servers

is always empty.

I already tried to restart Wildfire and everything, but it didn’'t work…

Still I get “No Servers Configured” …

What can I do?

I thought well if it works anyway I’'ll just ignore it, but when I click on “Phone Mappings”, nothing happens,

the screen of “General Settings” stays there. So the “No Servers Configured” obviously has an impact

Could anybody help me?

That would be perfect

Thanks a lot in advance!

Best regards,

Christian

Nobody?

Hi!

I had the same problem and digging a little revealed some missing things in my postgres database.

If you also has a posgres database, run the script below in pgAdmin3.

Maybe you need to modify the owner ‘‘wildfire’’ to fit your installation.

Enjoy!

Richard Gomes

drop table phoneServer;

create table phoneServer (

serverID int8 not null,

serverName varchar(255) not null unique,

hostname varchar(255) not null,

port int not null,

username varchar(255) not null,

password varchar(255) not null,

primary key (serverID)

) WITHOUT OIDS;

ALTER TABLE phoneServer OWNER TO wildfire;

drop table phoneDevice;

create table phoneDevice (

deviceID int8 not null,

device varchar(255) not null,

extension varchar(255) not null,

callerID varchar(255),

isPrimary integer not null,

userID int8,

serverID bigint not null,

primary key (deviceID)

) WITHOUT OIDS;

ALTER TABLE phoneDevice OWNER TO wildfire;

drop table phoneUser;

create table phoneUser (

userID int8 not null,

username varchar(255) not null unique,

primary key (userID)

) WITHOUT OIDS;

ALTER TABLE phoneUser OWNER TO wildfire;

alter table phoneDevice add constraint pD_userID_fk foreign key (userID) references phoneUser;

delete from jiveVersion where name=’‘asterisk-im’’;

INSERT INTO jiveVersion (name, version) VALUES (’‘asterisk-im’’, 2);

Richard,

thanks a lot for your answer!

Unfortunately I am not using PostgresQL, but MySQL and the internal Database of Wildfire. I have already had a look into the mysql-database to see if I can see an error regarding this problem but I didn’'t find anything (and had no idea what to look for anyway…)

Do you possibly know where to look? And what to do? I’'d really like to use this handy feature

Thanks and best regards,

Christian

Well as we weren’‘t able to solve the issue, we’'ve now installed the new Rc2-build and the new Plugin-Build and it works

Well, mostly as least… It takes some time until the system sets the user as “on the phone” but it never sets the user back to “online”

Does anybody know why that happens and what we could do to fix it?

Thanks a lot!

Christian

hello! but you’‘re not alone … ! I’'m enthusiast of Wildfire …

but with this last installation I’'m getting crazy on having it working with asterisk-im.

My issue seems to be related to mySQL database.

any idea about the structure, the name, values of the database/table I’'ve to look for ? and what to do ?

many thanks.

for your track, here is my context:

asterisk-im (1.2.2)

wildfire_3_2_0_rc2 (Embedded database)

mysql used for asterisk.

Here is my error- log when I try to “add” a new server.

2007.02.02 11:44:17 org.jivesoftware.phone.database.DbPhoneDAO.getPhoneServers(DbPhoneDAO.java:633)

java.sql.SQLException: Table not found in statement

at org.hsqldb.jdbc.Util.throwError(Unknown Source)

at org.hsqldb.jdbc.jdbcPreparedStatement.(Unknown Source)

at org.hsqldb.jdbc.jdbcConnection.prepareStatement(Unknown Source)

at org.jivesoftware.database.AbstractConnection.prepareStatement(AbstractConnectio n.java:36)

at org.jivesoftware.phone.database.DbPhoneDAO.getPhoneServers(DbPhoneDAO.java:625)

at org.jivesoftware.phone.BasePhoneManager.getPhoneServers(BasePhoneManager.java:1 05)

at org.jivesoftware.wildfire.plugin.phone.phone_002dsettings_jsp._jspService(phone _002dsettings_jsp.java:175)

Hi time2voip,

I run today into the same problem - and I solved it

The solution is that the beta distribution of the plugin is incomplete. It will only work if you are using mySQL as your database for wildfire. In the distri the sripts for enhancing the database of wildfire (see directory “plugins/asterisk-im/database”) are wrong: Table phoneServer is missing, table phoneDevice is wrong.

HowTo:

  1. stop your wildfire server

  2. copy the plug in the directory

  3. unpack manually

  4. change the database tables appropriately (you should know what you are doing)

  5. start the wildfire server

  6. configure the plugin via the webinterface.

There is an additonal bug in the webinterface: it is not possible to change phone mappings (changes are not stored). you have to delete and add again with the new values.

Regards,

Elmar

Thank you very much Elmar for your support.

Unfortunatly I don’'t know at this moment the record track and the structure of the database.

In other words, I don’'t know exactly where to put my hands.

So, I downgraded the system to previous version (wf 3.1.1 instead of 3.2.0) and I’'m using it with an old plug-in.

Hope to share with you quite soon the pleasure to use the 3.2.0 version …

see you,

Marc

Hi, can you give out the proper database schema.

I have searched the whole net, but can not find the official schema related to Asterisk-IM.

Thanks

For wildfire3.20, we must use the Asterisk-IM 1.2.2 Beta, which has the database schema problem issue.

Browse to /opt/wildfire/plugins/Asterisk-IM/database, you can get all the sql for different Database management system, among them, only sql script for mysql seemed like ok.

It is the version 2 database, and the majore change for version 2:

  1. additional table “phoneServer”

  2. additional filed “serverID” in “phoneDevice” table.

  3. INSERT INTO jiveVersion (name, version) VALUES (’‘asterisk-im’’, 2), the version number should be 2 instead of 0.

I have not tested it yet, but I have read the post above, that guy said just manuly extarct plugin jar file and modify the script, and then reboot the wildfire will fix the bug. I wonder if we should drop the old version database before create the new database, or the wildfire will override the old verion with the new version automatically.

Hopefully it may help!