powered by Jive Software

No Tray Icon in Linux

Hi All,

I’'ve searched far and wide through this forum, but cannot seem to find a solution for this problem:

I’‘m currently using Spark 2.5.4/2.5.2 on linux, and am unable to the tray icon to appear. I’'ve tried on two different distributions, using both JDK1.6 and JDK1.5:

  • Kubuntu 7.04 32bit

  • Suse 10 32bit

The problem is that I start Spark using the standard startup/Spark script. Spark opens up and I can login successfully, but no tray icon appears. I’'ve updated the JDIC components in ~/Spark/lib/linux, but it still refuses to show me a tray icon. If, however, I close the window, the process stays running, but there is no icon in the system tray to double click on to open it up again. The only way to bring it back it to kill the process and start the app again.

The only errors I receive on both linux distributions when I startup is:

ls: /opt/Spark/lib/windows: No such file or directory

I also have the following error in the ~Spark/log/error.log:

Exception on commit = java.io.IOException: Can’'t find registry file

I’'m absolutely stumped as to why this is happening since in the previous 1.x.x Spark versions, it worked like a charm.

Essentially all I’'m doing is untarring the Spark download, and modifying the Spark startup script to point towards my local JDK:

e.g. ~/Spark/Spark: INSTALL4J_JAVA_HOME_OVERRIDE=/opt/java

What am I missing? Thanks in advance.

same for me on osx… but I thought I was alone (had a thread about it)

Another me too, but on win32. Additionally, I have confirmed that the tray icon is missing in OS X as well.

and me on FreeBSD/KDE

may be developers say anythings about this?

on gnome (freebsd 6.2) icon exists…

The version of kde I have running is 3.5.6 if this is any help.

Hello,

I can confirm this issue on Windows 2000. The Spark process is running an chat is possible. However, the icon in the taskbar is missing.

Walter

+1 here.

Same problem with Spark 2.5.4/KDE-3.5.6 JDK1.6

+1 Same problem, KDE 3.6 on Debian Testing. This error is critical, Spark is unusable. We’'ve payed for Fastpath and we need Spark operating. Please correct the problem ASAP.

I’‘ve tried this on OSX and Ubuntu and haven’'t had any issues. Could you guys post some more details and error logs?

ls: /tmp/Spark/lib/windows: No such file or directory

is the only error printed to console. Logs file are just empty.

On Ubuntu you probably run GNOME. And this looks like KDE problem (on Linux at least).

Message was edited by: haizaar@gmail.com

Message was edited by: haizaar

I have the same problem using Gnome with Spark 2.5.4.

It works fine with 2.0.1 however.

Cheers,

Ben

This issue has been logged here :

http://www.igniterealtime.org/issues/browse/SPARK-782

Same here. Win32 XP. Was working on 2_5_3

The same problem on Debian Etch 4.0/GNOME 2.14.3/Spark 2.5.4 and Fedora Core 7/GNOME 2.18.2/Spark 2.5.4

Without tray icon it’'s really unusable.

This is fixed in the upcoming Spark 2.5.5.

Cheers,

Derek

http://www.igniterealtime.org/issues/browse/SPARK-782 is still open.

Can you point me to relevant SVN commit? - I’'d like to merge it to 2.5.4. This bug is show-stopper for me and I do not want to wait for 2.5.5 (providing that there is no planned release date yet).

Thanks.

The problem is not fixed in Spark 2.5.5

I am running openfire 3.2.2 on a openSuSE 10.2 server

client: openSuSE 10.2/KDE 3.5.5 /Spark 2.5.5

On Linux, make sure you are running JRE 1.6+. You should have tray support with it.

Cheers,

Derek

It still isn’'t working for me with Spark 2.5.5 either.

The tray icon just doesn’‘t show at all, although when I tick the Start In System Tray it doesn’'t crash like it used to.

Is it something to do with KDE? Because I’'m running the latest Sabayon with the latest KDE etc. And I just installed a new version of the laster Java to use with it, but still, nothing. I even tried replacing the libtray.so with one I stole from somewhere else, but still nothing.

Is there anyone else with this problem?

Thanks,

Sam.