powered by Jive Software

No Tray icon on Ubuntu 12.04 with Spark 2.6.3

Hi,

I do not get a tray icon when running Spark on Ubuntu so if I close the window I can’t get back to the application. Is there supposed to be a tray icon? This is the first time I have installed Spark, as we are trialling OpenFire.

Thanks,

Tamsin

please see if the latest nightly build works for you: http://www.igniterealtime.org/builds/spark/dailybuilds/spark_2_7_0_653.exe

Most probably it won’t work on Ubuntu

The only nightly build for linux i can find in Bamboo is this RPM http://bamboo.igniterealtime.org/artifact/SPARK-NIGHTLYRPM/JOB1/build-651/RPM-Pa ckage/RPMS/x86_64

Hi that looks like an exe - the problem is on Ubuntu?

whoops! I got a little copy/paste happy!

well, i can verify the tray icon works on Fedora using KDE desktop. What desktop are you using on Ubuntu? How are you launching Spark?

Release 12.04 (precise) 64-bit

Kernel Linux 3.2.0-40-generic

GNOME 3.4.2

Spark is launched by executing the “Spark” file in the install directory. I made sure my user has read write access to all folders within the Spark directory, as I found mention of this in some older issues.

Thanks for your help.

Maybe Gnome doens’t play nice… I’ve not used Gnome myself in years. When you say you are launching it using the Spark file, are you using the terminal to launch it, or just double-clicking it?

Also, since you mentioned the read/write privs, spark will attempt to make a .Spark file to contain the user account’s preferences and other things in the current users home directory.

so, ~/.Spark

I don’t think that’s your problem, just wanted to make sure you knew that too.

Have you verified Spark is actually still running when this happens via TOP or something? It’s possible Spark is not running anymore, and therefore there would not be a tray icon.

Hi,

Thanks for the suggestion - I started up in Unity and I get a tray icon!

I hate unity though! Is it likely to get fixed for gnome? Or is there anything I can do about this?

Thanks,

Tamsin

This is hard to tell, but I think it’s likely Gnome that’s causing this.

Maybe this applies (it’s on the arch forums, but things may be similar)

https://bbs.archlinux.org/viewtopic.php?pid=1054054

In particular, I’ve seen the package libsvg mentioned in a few other forums that indicate it has to do with tray icons. Maybe re-installing that package may help under Gnome?

Also, try making a new user account under Gnome, login to that account and run Spark, see if the icon is there.