powered by Jive Software

Not Able to connect to BOSH

Hello Team,
I have setup openfire server. Can you please suggest what settings we need to pick form Openfire server to start chat using converse js as client?

Thanks,
Neeraj Kumar

Enable BOSH in server settings and make sure set port is allowed in firewall (if present) and forwarded (if needed).

I already enabled BOSH by enabling Setting->http-bind.

I am access my openfire Admin panel on: http://192.168.100.37:9090

And BOSH http binding is showing different IP: http://192.168.40.54:7070/http-bind/
But When I hit BOSH url on Browser it doing nothing. Anything I am missing in setting.

I’m not sure if http://server:7070/http-bind/ should give any answer. It shows error for me also. But if i install inVerse plugin, i can access it on http://server:7070/inverse/, so BOSH is working (inVerse is a plugin using Converse.js).

I want to check if my bosh is running correct or Not. I am able to do chat using Spark client but it picks all the compatible settings from Openfire itself. I want to know what settings it is picking itself and it is working fine.

I want to use those settings(bosh url, domain etc) in my converse.initialize function.

I installed inVerse web client on my Openfire server. I did the settings. Now it gave me two URLs
http://192.168.40.54:7070/inverse/
https://192.168.40.54:7443/inverse/

When I hit first one in new tab of browser it is giving below error. PFA

Hello wroot,

I am able to see inVerse login page if I use http://192.168.100.37:7070/inverse/ . 192.168.100.37 this is my Host IP. Now I am able to login and doing chat with users.

Thanks

I guess when you first did Openfire setup you used IP address as domain name, but your IP changed since then. Another argument why using IP for domain name is very bad. It might be ok for testing, but for production server make sure to use proper domain name with DNS resolving.

I will keep it mind and will test with Domain name.
Can you suggest me one thing that chating functionality working fine but When I want to use those settings(bosh url, domain etc) in my converse.initialize function it does nothing.
converse.initialize({
bosh_service_url: ‘http://192.168.100.37:7070/’,
keepalive: true,
jid: ‘admin’,
authentication: ‘prebind’,
prebind_url: ‘http://example.com/api/prebind’,
allow_logout: false,
debug: true,
prebind: true,

});
What I am doing wrong with above code
Thanks

Can’t help with this. Not a developer and don’t have much experience with Converse.

This is more of a question for the Converse.JS developers, instead of for this community. One thing that is highly suspicious to me, is that this snippet indicates that prebind authentication is to be used, while the prebind URL is an example. That is unlikely to lead to success. Have a look at https://conversejs.org/docs/html/index.html

Finally got success by below code snippet.
converse.initialize({
auto_list_rooms: false,
auto_subscribe: false,
bosh_service_url: ‘http://domain_name:7070/http-bind’,
hide_muc_server: false,
prebind: true,
jid: ‘xmpp_user_name’,
password: ‘password’,
auto_login: true,
show_controlbox_by_default: false,
xhr_user_search: false
});

Thanks

1 Like