powered by Jive Software

Not able to login to openfire admin console

I have installed freshly openfire ver 4.1.3, and it asked me to give old and new password. I don’t know the old/current password of admin. I tried uninstalling and reinstalling as well but still its not helping. In addition I read some solution about create new account through Spark and then define that id into config as authorisedadmin login, but unfortunately spark is not taking my server name. This could be because I have installed openfire on standalone windows 7 machine which is not part of any domain. However logically it should work because while configuring the openfire I am either giving the machine name (Sony-PC) or the localhost IP ( as both of these are defined in my etc/host file and if I try to ping the localhost or my machine name then it resolves locally and also openfire admin console opens up with the same localhost or machine name or with

Shouldn’t uninstallation and reinstallation remove any stored admin password? What should I clean to remove admin password from cache so that when I reinstall it it should be fresh and shouldn’t ask me current admin password or it resets admin password.

Can someone please help me here?


From the Openfire: Installation Guide

Note: On Windows systems we suggest using a service to run Openfire (read the Windows Service section below). When using Openfire Launcher on Windows Vista or newer with UAC protection enabled, it has to be run with Run as administrator option, to be able to write changes to config and embedded database (if used) stored in C:\Program files\Openfire\ folder.

Thanks Wroot for quick reply, however this is not the thing that I am looking for. Sorry If my note wasn’t good enough to explain the issue…

I am the local admin on that machine and have admin privilege, however even after installing freshly, Openfire setup admin console asks me current password for admin and when I am giving admin then its not taking. Also attaching the screenshot image of the issue/error.

Hope this good enough to explain the problem now. I also tried connecting HSQLDB through hsqldb viewer but don’t have username and password for it, so tried SA and blank password per community instruction. However even after that as well its not showing any OfUser table.

Can you please help what else I can do to either know the openfire admin password or to reset it?

That’s exactly the point. Even if you are admin, UAC is protecting from a process making changes in Program files. Openfire is storing its config and embedded database in its folder in the Program files. That’s why you get the prompt for a current password on a new installation. Openfire just can’t write changes to its config and goes nuts. It also should take very long between steps as it tries to write changes many times and fails. Anyway, running as a service is still the best solution, so check that option. Or install into C:\Openfire if you want to run it with a launcher and do not want to use Run as admin.

1 Like

Thanks… Appreciate your help Wroot! Followed two commands “openfire-service /install” and “openfire-service /start” and It’s working now…