powered by Jive Software

NPE in admin.setup.setup_002dfinished_jsp

I did a brand new install of Openfire on Linux today. On the last page of the setup process, I tried various ways of changing the admin email address and password, but kept getting the NPE below. I could see that changes were taking effect in the MySQL DB, but the setup wouldn’t complete, so the server remained unusable. Finally I was able to Sklp the step without changes (which, I recalled, is how I tested this page most frequently back when I worked at Jive), and I was finally able to complete the setup. Arghh, I knew I should have QA’d this page more thoroughly back when I worked there, and now it’s come back to bite me .

Anway, the setup did complete, as mentioned, so I’m not being held up. Just thought I’d pass this along…

2007.12.04 13:57:21 /setup/setup-finished.jsp

java.lang.NullPointerException

at org.jivesoftware.openfire.admin.setup.setup_002dfinished_jsp.jspService(setup 002dfinished_jsp.java:74)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:65)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:69)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:211)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:313)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)

at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:830)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)

Hola Marilyn,

Welcome back!!! This issue has been reported a few times and it seems to be related to session expirations. Can you confirm that that was your case?

Thanks,

– Gato

PS: We still owe us a dinner. Let me know if you are available this or the next weekend.

Hola, Gato!

My search for NullPointerException did not turn up that archived thread, so thanks for the link.

During setup, I had spent a good chunk of time on the JDBC connection page, as I had to make some changes on our end before that worked. But all that was resolved and the setup proceeded, so the session was recently very active. I assume session timeout would take effect only after some amount of idle time, and my session had not been idle when I hit the NPE. Can the setup session really time out while it’s actively being used? Even if this is so, an NPE seems a rather unfriendly way to signal a session timeout.

p.s. Getting together for dinner sounds great! I’ll check and get back to you (via direct email).

Gracias,

Marilyn