powered by Jive Software

Null point exception error

I see the “null point exception” error while proceeding with the configuration. This is a Java related error and I’'ve googled about it and found some URLs regarding debugging the error message.

http://jeremy.zawodny.com/blog/archives/000422.html

http://publib.boulder.ibm.com/infocenter/wsphelp/index.jsp?topic=/com.ibm.faq.wa s5/html/Runtime/1003414.html

As far as I see, this is something to be done on the Java code to fix the error message.

Any ideas?

Can you post the complete error that you are seeing?

Thanks,

Alex

HTTP ERROR: 503

service_unavailable

RequestURI=/index.jsp

You said you saw a Null Pointer Exception, where did you see that and can you post it?

Thanks,

Alex

This is what my programmer sent to explain what he has been seeing - what the problem is specifically. He sent jpg screenshots - but I don’'t see a way to upload them for you so I am just copying the last one with the error message.

step-1: (See w1.jpg) the first screen that comes up for installation. (work status : OK)

step-2: (See w2.jpg) the second screen that comes up for server setting (work status : OK)

step-3: (See w3.jpg) the third screen asking for server selection (work status : OK)

step-4: (See w4.jpg) the fourth screen asking for database configuration (work status : OK)

step-5: (See w5.jpg) the fifth screen that comes up after database is installed successfull (work status : OK)

step-6: (See w6.jpg) the sixth screen after clciking continue in the image w5.jpg (work status : ERROR)

The screen he sent says:

HTTP ERROR:500

Internal_server_error

RequestURI=/setup/setup-profile-settings.jsp

Caused by:

java.lang.NullPointerException

at org.jivesoftware.util.JiveGobals.deleteXMLProperty(JiveGlobals.java:492)

It goes on and on with the “at” messages.

Does that help clarify?

Are you updating from an older Openfire-Version? I had the same problem while updating from Openfire 3.3.0 to 3.3.1 and solved it on the following way:

I uninstalled the old RPM *), deleted the old openfire-directory manually and installed the new RPM.

*) my Server is running on an SuSE-Linux.

Coolcat

Message was edited by: Coolcat

++++++HELP!!! I am receiving this same error on my Mac Pro. This is a fresh install and doesn’'t occur until after I finish the setup and log into the to the console at which point I receiv the dreaded:

HTTP ERROR: 503

service_unavailable

RequestURI=/index.jsp

Followed by the Java Null exception stuff. This is a clean install a new fairly new system. Java and MySQL are both working because I can actually get to the User Summary page if I manually overide the URL.

Can someone please help me with this. The Install guides are out of date and don’'t even mention the Mac OSX package installer option?

Thanks in advance,

Andrew

  • FALSE ALARM!!! It’‘s Working Sorry for the Histeric’'s!!! ****************

I just uninstalled and reinstalled making sure the port were set right for the web application and its all working.

Message was edited by: adun9002