powered by Jive Software

OD ldap

Hi All

Setting up openfire and am having some trouble with the ldap integration. I am using ldap from a 10.5.8 OS X Server. The LDAP is working as I hav various other devices using it.

I have managed to get as far as getting open fire to import the users and the the groups. Although none of the users are part of the groups.

What I have used is (server being leopardserver.hb).:

Base DN: dc=leopardserver,dc=hb

Administrator DN: is blank

Username Field: uid (default)

Group Field: cn (default)

Member Field: member (default)

Description Field: discription (default)

I have tried the to use:

Base DN: cn=users,dc=leopardserver,dc=hb

which then ends up with me having the users as groups. I assume that the cn in the Group filed is refrancing the cn in the Base DN and that is why this is happening.

Can any one give me some advice on what I should put into the Base DN as a refrance for the groups that I could then use in the Group Field.

Thanks for you help

Having a play around

I am thinking that my base DN needs to be something like

Base DN: uid=users,cn=groups,dc=leopardserver,dc=hb

Then from there my Username Field could be:

Username Field: uid (default)

and my Group Field could be:

Group Field: cn (default)

Only problem with this is Base DN: uid=users,cn=groups,dc=leopardserver,dc=hb does not seem to work. Any one got any ideas?

Thanks

Having taken some time off on this I have decided to give it another go as I have some more free time.

What I have managed so far is this

**Connection Settings
**

Base DN: dc=“leopardserver”,dc=“hb”

Administrator DN: uid=“diradmin”,cn=“users”,dc=“leopardserver”,dc=“hb”

Password: diradmin’s password

Group Mapping

Group Field: apple-group-realname

Member Field: memeberuid

What this results in is all my users coming through. All my created groups and not the system groups coming through (the way I want it). Although there are no members to the groups and they are still empty.

Any advice would be good please. I can authenticate with the users so it seems to be something that is not linking the users to the groups.

Hi,

it may help if you could post your LDAP structure.

``cn=users,dc=leopardserver,dc=hb´´ … all users are in this group

``uid=random,cn=users,dc=leopardserver,dc=hb´´ … one random user

?? ``ou=groups,dc=leopardserver,dc=hb´´´ … all groups are in this group

?? ``ou=random,ou=groups,dc=leopardserver,dc=hb´´´ … one random group

?? memberuid: uid=random,cn=users,dc=leopardserver,dc=hb´´ ... a group does use thememberuid´´ to list the members.

LG

This is the infomation I pulled from the server using JXplorer. Hope this helps.

Users:

cn=users,dc=leopardserver,dc=hb

Groups:

cn=groups,dc=leopardserver,dc=hb

The Group that all my users are in:

cn=staff,cn=groups,dc=leopardserver,dc=hb

Admin User:

uid=diradmin,cn=users,dc=leopardserver,dc=hb

Thanks

hi…

i have got a task to connect openfire server with xmpphp client. i tried hard but not got success. When i connect to openfire then only blankpage is shown.

code is as-

<?php session_start(); header('content-type', 'plain/text'); // activate full error reporting //error_reporting(E_ALL & E_STRICT); include ("/XMPPHP/BOSH.php"); print "
";

#Use  XMPPHP_Log::LEVEL_VERBOSE to get more logging for error reports

#If  this doesn't work, are you running 64-bit PHP with < 5.2.6?

$conn  = new XMPPHP_BOSH('10.1.0.23', 5222, 'admin', 'asdfghjkl', 'xmpphp',  'hitech.com', $printlog=true, $loglevel=XMPPHP_Log::LEVEL_INFO);

$conn->autoSubscribe();

try {

if(isset($_SESSION['messages'])) {

foreach($_SESSION['messages'] as $msg) {

print $msg;

flush();

}

}

     $conn->connect('http://10.1.0.23:7070/xmpp-httpbind',  1, true);

#while(true) {

$payloads =  $conn->processUntil(array('message', 'presence', 'end_stream',  'session_start'));

foreach($payloads as $event) {

$pl = $event[1];

switch($event[0]) {

case 'message':

if(!isset($_SESSION['messages'])) $_SESSION['message'] = Array();

$msg =  "------------------------------------------------------------------------------   ---\n{$pl['from']}: {$pl['body']}\n";

print $msg;

$_SESSION['messages'][] =  $msg;

flush();

$conn->message($pl['from'], $body="Thanks for sending me  \"{$pl['body']}\".", $type=$pl['type']);

if($pl['body'] == 'quit') $conn->disconnect();

if($pl['body'] == 'break') $conn->send("");

break;

case 'presence':

print "Presence: {$pl['from']} [{$pl['show']}] {$pl['status']}\n";

break;

case 'session_start':

print "Session Start\n";

$conn->getRoster();

$conn->presence($status="Cheese!");

break;

}

}

#}

} catch(XMPPHP_Exception $e) {

die($e->getMessage());

}

$conn->saveSession();

print  "
"; print ""; ?>

I don’t think your question has any relevance to this thread. If it does it is not very clear what you are asking. I would suggest starting a new thread regading your issue.

Hi,

did you set ldap.groupMemberField to memeberuid?

LG

Looks like I have.

See screen shots of what I have done. Maybe some one can spot a mistake.