powered by Jive Software

OF 4.4.0 & 4.3.2 plugin manager

Can not restart plugin installed.
it reads
“the plugin manager is currently running it may take time for the installed plugins to complete”

Any idea on how to solve this issue? What actually is wrong?

Much Obliged

Check the logs ar /openfire/logs/all.log
You can also restart the server.

What all exists in your installation’s plugins folder?

Howdy,
Right know whatever comes with the core install.
I got a “search” update notification, did the update but it just wont reload. Next i installed the HTTP file upload and same occurred, it installed well but wont reload.

What say you?

Howdy,
Did restart the server (server runs windows 64bit) and same…no reload.

Here is some of whats in the log:
“[pool-2-thread-1]: org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file C:\Program Files\Openfire\plugins\httpfileupload\lib\guava-19.0.jar”

“[pool-2-thread-1]: org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file C:\Program Files\Openfire\plugins\httpfileupload\lib\httpFileUpload-lib.jar”

“org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file C:\Program Files\Openfire\plugins\httpfileupload\lib\httpfileuploadcomponent-1.1.3.jar”

“org.jivesoftware.openfire.container.PluginClassLoader - Unloading plugin JAR file C:\Program Files\Openfire\plugins\httpfileupload\lib\plugin-httpFileUpload.jar”

“org.jivesoftware.openfire.container.PluginManager - Successfully unloaded plugin ‘httpfileupload’.”

“org.jivesoftware.openfire.container.PluginMonitor - Finished processing all plugins.”

However, back in the plugin section, the plugin appears as in need of restart, when restarted it just wont complete the action. The occurred when i was using OF 4.4.0 so i uninstalled, cleaned the folders, and installed 4.3.1 and later 2 with the same outcome.

Here is the thing, when was on 4.3.2 all worked just fine, after upgrading to 4.4.0 it all went down the tube…

Any ideas?

Can you share a screenshot of how “plugin appears as in need of restart”? Is plugin not working at that time? When i try to restart a plugin it also shows “the plugin manager is currently running it may take time for the installed plugins to complete” and then i just refresh that page. The thing is that there is no automatic refresh in this place. Confusing message.

These buttons are not indicators that plugins need a restart. They are just there, so you could restart a plugin if it misbehaves. And the message about plugin manager is not hiding automatically, which is confusing. Everything is working as it should in your case.

https://issues.igniterealtime.org/browse/OF-1810

Thank you.

As i trun to the system properties section, i do not see the plugin. This suggests that after uploading the plug in, it reads that it was uploaded succesfuly however its not in the system properties.

Is system properties the correct place for managing/editing the plugins?

Which plugin in particular? Usually system properties are not shown and you have to create one if you want to change default values.

well…the HTTP file upload. It used to be prior to the curent version update at the server properties section.

Not sure what you mean exactly. When i check 4.3.2 i don’t see any menu for HTTP File Upload menu in Admin Console. And it currently has just one system property that you can create and set - plugin.httpfileupload.maxFileSize

I will try and explain again. I was using version 4.3.2 and all was good as gold. I updated to the 4.4.0 and it all started to break apart.

I install the httpfile upload, it says it was installed ok, i see it in the plugin folder, however i dont see it under the server properties section.

Took your advice and created the plugin.httpfileupload.maxfilesize and got an error message.

Within the error log i get alot of data something regarding org.eclipse.jetty.util.thread and thread.run unknow source

I instaled another plugin, user status, just to test, and i get the same issue. It installes, its in the folder but not showing under system properties.

I’m afraid without a screenshot of older system I won’t be able to understand what server property you mention. When you install plugin its system properties not always automatically appear on System Properties page. Most of the time you have to create them manually to set a value different than default.

Let’s change the course of investigation. What is broken about plugins you use? You used http file upload? With what application? Spark, other client like Converse, Pade, Gajim, etc. Or maybe some custom developed application? So, it was working for you with 4.3.2 and you were able to upload files. With 4.4.0 you can’t upload files anymore? Button not showing up in a client or giving error when trying to upload? In that case just zip the /openfire/logs/all.log file and attach it here.

I might be wrong, but it seems that you are expecting something after plugin’s installation, that probably shouldn’t occur. Many plugins don’t have any menu or properties and just work.

After dealing with the issues in 4.4.0 are uninstalled it. Reinstalled 4.3.2 and had the same problem so i uninstalled it and reinstalled 4.3.1 which works kinda better but still no luck with any of the plugins i choose to install i.e. httpfileupload.

When i was working with 4.3.2 prior to the upgrade to 4.4.0 i was able to install the httpfileupload and all worked just fine i used conversations and Spark, all was just fine. After the upgrade to 4.4.0 i started getting error screens within the actuall admin page not with apps such as conversations/Spark.

I will sed the log file.

Sorry but the system is not allowing new users to attach files…

So, you are saying that plugins were working after 4.4.0 update (you were able to upload files in Spark and Conversations), but it showed errors in Admin Console? What kind of error? Maybe you can copy your server and put it on some test PC and then update it and create screenshots of such errors.

You can upload your log file on some file sharing site and put a link here. Or paste it into pastebin.com and give a link here. Just go through it and mask your real domain, if this is sensitive information.

4.3.2 only had one bug with IQ stanzas fixed, which only should affect messaging, not plugins. Not sure why 4.3.1 works better than 4.3.2.