powered by Jive Software

OF - unable to load profiles for some user when auth with office 365

Hi,

We are on OF 3.8.2, Spark 2.8.1.
We are authenticating our users through Zimbra server (Only users are being authenticated, Groups are created manually in DB and not updated from LDAP).
We wanted to move the authentication from Zimbra to Office365. This has been completed and server is able to use O365 now.
BUT there is an intermittent issue, where some users are unable to see their profile (Groups, users, vcards etc) while other has no issue at all.
The Spark client signs in but nothing is visible.

We ran few tests and every time result is different. In those tests we removed local profile directory. For some users it worked for one time, for some it didin’t work at all.
Another test we ran that when Spark fails to load the profile, We logged into the OF admin panel and tried to view the Users/Groups page. It took a while to load all users but when it does the Spark started showing the user’s profile (We had to re-login in spark client of course).
The situation is fuzzy and i am unable to pin point the exact issue.
I didn’t find any relevant entries in logs as well.

Need your expert advice here please.
Thanks.

Moved this to Openfire Support as it relates more to Openfire. Although you can check with some other client like Psi, Pidgin. Maybe other client is able to show roster while Spark can’t. You can also enable debugger in Spark (on Login screen, Advanced menu) and check what incoming packets it receives. There should be SharedGroupsInfo close to login.

Other than that i have no ideas. Maybe @speedy will have as this is close to AD integration which he has lots of experience with.

Btw, have you only checked Openfire logs? Check Spark’s as well at C:\Users\User\AppData\Roaming\Spark

One notice able behavior is that for some users it starts working once i log into admin panel and click on Users/Groups link.
Here is the flow.
1- It’s been a while since i logged out of admin panel, say 8, 10 hours. I logged in Spark. The profile doesn’t load, (Don’t see Vcard, profile pic, Groups, any thing)
2- I log out of the spark and log into the web admin panel.
3- Click on Users/Groups link, which take some good 1, 2 minutes to load (it goes out to Office365)
4- I logged in Spark client again and i can see everything here.

So i am thinking could it be due to “refresh” time of user’s table? Is there a way / property to control it?

In local logs of Spark I see too many of following errors, while Spark was in issue.

Feb 11, 2018 4:58:40 AM org.jivesoftware.spark.util.log.Log error
SEVERE:
org.jivesoftware.smack.SmackException$NoResponseException: No response received within reply timeout. Timeout was 10000ms (~10s). Used filter: IQReplyFilter: iqAndIdFilter (AndFilter: (OrFilter: (IQTypeFilter: type=error, IQTypeFilter: type=result), StanzaIdFilter: id=8htId-43)), : fromFilter (OrFilter: (FromMatchesFilter (full): null, FromMatchesFilter (bare): iyousaf@spark.domain.com, FromMatchesFilter (full): spark.domain.com)).
at org.jivesoftware.smack.SmackException$NoResponseException.newWith(SmackException.java:106)
at org.jivesoftware.smack.SmackException$NoResponseException.newWith(SmackException.java:90)
at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:229)
at org.jivesoftware.smack.PacketCollector.nextResultOrThrow(PacketCollector.java:213)
at org.jivesoftware.smackx.iqprivate.PrivateDataManager.getPrivateData(PrivateDataManager.java:163)
at org.jivesoftware.smackx.bookmarks.BookmarkManager.retrieveBookmarks(BookmarkManager.java:235)
at org.jivesoftware.smackx.bookmarks.BookmarkManager.getBookmarkedConferences(BookmarkManager.java:98)
at org.jivesoftware.spark.ui.conferences.BookmarksUI$4.run(BookmarksUI.java:178)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Well, it looks like Openfire is not pulling info from Azure AD automatically. Have no ideas why though. speedy is using AD, but not Office 365. Not sure if he can help with this. I on the other hand never used even regular AD integration. So, sorry, can’t help.

no clue on this one either. what happens when you use a different client? does the info pull in then? Is it always the same users or does it seem random? Spark caches the vcard info, so its possible that cache is not working correctly. If you pull up the vcard info in spark and hit “refresh” does it load? How many objects do you have in AD?