powered by Jive Software

Offline UTF-8 encoded messages are saved wrong openfire 4.2.3

Offline messages are saved wrong , get ??? ??? ??? charsets

how i can fix it on 4.2.3 and Ubuntu 16.04 + Mysql .

Find one topic on stackoverflow , but idk its works or not on new version?

Thanks

MySQL does not have proper Unicode support, which makes supporting data in non-Western languages difficult. However, the MySQL JDBC driver has a workaround which can be enabled by adding

?useUnicode=true&characterEncoding=UTF-8&characterSetResults=UTF-8
to the URL of the JDBC driver. You can edit the conf/openfire.xml file to add this value.

Note: If the mechanism you use to configure a JDBC URL is XML-based, you will need to use the XML character literal & to separate configuration parameters, as the ampersand is a reserved character for XML.

Also be sure that your DB and tables have utf8 encoding.