powered by Jive Software

OFMeet no video to other partecipants


Don’t know is someone else resolved already the problem but I do think is something still to be treated.

My config is:

OF Server rel 3.91 with Jitsivideobridge, Rayo and Jinglenodes plugin in place. The server has also the settings to forward to 2 stun server the stun requests but it’s not a stun server at all.

Trying to connect 2 clients (one placed outside with it’s own public ip) and another one inside the network the video connection cannot be arranged.

I do underline that Jappix webrtc plugin that has the google stun server cabled in works fine.

What I see on wireshark on the external client side is a sequenct of stun request sent to the public ip of OF but it seems not to respond and this coud be the reason why the connection isn’t established.

I did enabled the line:

useStunTurn: true

in the config.js file with no result, is there any place on which force the stun parameters?

Thanks in advance for the help.


edit main.js and change

window.RTC.rayo.pc[videobridge] = new window.RTC.peerconnection(null, {'optional': [{'DtlsSrtpKeyAgreement': 'true'}, {googIPv6: config.useIPv6}]});


window.RTC.rayo.pc[videobridge] = new window.RTC.peerconnection({ "iceServers": [{ "url": "stun:stun.l.google.com:19302" }] }, {'optional': [{'DtlsSrtpKeyAgreement': 'true'}, {googIPv6: config.useIPv6}]});

Hi Dele,

thanks for the quick reply.

Just to understand if it set it up properly. I did change the config.js accordingly to the instructions and substituted the lines you mentioned on this post.

Unfortunately it does not work and keeps searching for stun at the address of the xmpp server (i cleared cache of both browser before any test).

Did I have to add something else?



dele, have you had time to take a look or to give me a possible solution on this?

Thanks for the help


Try installing the openfire STUN plugin


Ok Dele,

i’ll try again.


Hi Dele,

just retested after enabling the stun again without success.