powered by Jive Software

ofRoster table dont't exist in openfire db

Any one know how to fix this? I can’t add roster item for user. I use openfire 3.8.2 for Mac

I don’t know a solution to your specific problem, but I’ve had other problems with the 3.8.2 Mac version.

I tried to run it on Mac 10.7 (Lion).

It behaved very strange, e.g. suddenly I couldn’t log in because Openfire didn’t send a response during TLS negotiation. Often I also could not access the admin web UI. And I couldn’t stop/restart Openfire from my settings pane.

After googling, it turned out, others have also problems with the Openfire Mac version on Lion and people suggested it was the launcher.

I ended up using the Linux version and installed that one on my Mac (in my home directory for simplicity, I only needed it for testing).

Until now it is stable and I am happy with it.

I don’t have a nice Openfire logo in my settings pane, but instead I have to start/stop it via the console, but I am fine with that.

I don’t know if your problem is related though.

According from the image you posted, you try to set the JID test@127.0.0.1.

I think this is not possible. For the domain part, you have to specify a domain name, not an IP. If the user is local, use the domain, which is set for your Openfire instance. You can see it on the start page.

3ks for ur advice,i can use xxx@127.0.0.1 log in a xmpp Demo。

My domain name is 127.0.0.1

I will try to change the domain name,see what‘ll happen。

i create ofRoster table manually and now it works well