powered by Jive Software

Older gateway.jar files

I am looking for a version of IM Gateway that will work with Wildfire 3.1.1. I have found a few beta versions on this site but none that are compatible. I am requesting help from anyone who may have a compatible file downloaded locally.

Thanks in advance!

I’‘m afraid there will never be another gateway plugin release that works with anything pre-openfire. Somewhere in this forum there’‘s the last build of the gateway for the wildfire series. Unfortunately I don’'t really know where it is anymore. =/

Ok, thanks for the insight.

The old wildfire pages are still online.

IM Gateway 1.0 can still be downloaded from here: http://www.igniterealtime.org/projects/wildfire/plugins.jsp

Thanks for the suggestion. Unfortunately that version is good for 3.2.0. I still have 3.1.1. Any suggestions on finding an IM Gateway for that version?

Thanks!

Unfortunately, you are mostly out of luck. =( 3.2.0 became the minimum version for gateway.jar during it’‘s Wildfire days because there were some key internal changes in Wildfire that were necessary for the gateway plugin to function. At latest you could possibly find one of the early beta releases but I would not recommend that at all and I couldn’'t offer any support for it what-so-ever. =/

I hate to ask, but is there any reason why you haven’'t upgraded to Openfire?

Thanks for the information! I do appreciate it. The resistance to upgrading to Openfire is my being a scaredy. I didn’'t do the initial setup. I have begun investigating the upgrade path.

On that topic, is it required to upgrade to 3.2.0 Wildfire before going to Openfire or can I simply parallel install and migrate the configs?

Thanks again

Naw, you should be able to upgrade directly from Wildfire 3.1.1 to Openfire 3.3.1 or whatever. Not a lot -really- changed, it’‘s just internal mechanisms got renamed and the plugin had to be compiled to use object org.jivesoftware.openfire instead of org.jivesoftware.wildfire in a lot of places, which broke backwards compatibility. Generally server upgrades are easy with it. Openfire will likely be installed into a different directory than wildfire so basically you just have to unpack it, replace openfire/conf/openfire.xml with wildfire/conf/wildfire.xml (note that it changed from wildfire.xml to openfire.xml), copy over your resources/security/keystore and truststore from wildfire to openfire, fire up openfire and you should be running smooth. It’‘ll automatically upgrade any databases it needs to. (that said, I’‘m always a proponent of making a backup of your db before upgrading in case something does go wrong … not that i always follow my own adviice) If you are using the embedded db, you will also need to copy it over from wildfire to openfire. It’'s fairly straightforward =)