powered by Jive Software

Older Openfire Release

Does anyone know where I can get an older release of openfire that will run on my Mac OSX 10.3.9 Server? The new release will not even install all the way.

You need only change the URL of the current release to a past release version number. For instance this used to be for 3.4.4 and now is 3.3.3:

http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3_3_3.dmg

What version of Java does your server have? This might affect your ability to go back very far…

I have Java 1.4.2 v2.3.

The setup gets to the same point every time. It gets to within a hair of the end of the progress bar and then tells me there was an error during install. I can’t do anything with it. I would like to use my Mac Server but I also have a windows machine that it runs on. I’ve tried loading 3.3.0, 3.3.3 & 3.4.4. They all do the same thing.

Hi Scott,

BenV is completely correct when he said your version of Java is going to effect your ability to run Openfire. In fact, you’re going to have to upgrade to Java 1.5 to use any prior version of Openfire (or even Wildfire). The only version of Jive’s Jabber/XMPP server that worked with Java 1.4.x was way back when it was called Jive Messenger and it was a commercial product. Java 1.5 is available for OSX 10.4.x through Apple’s Developer Program (free registration is required).

Cheers,

Ryan

JAVA 1.5 will not install on Server 10.3.9. It requires OSX 10.4.6 or later.

Oops, I thought you had written that you were running OSX 10.4.

Unfortunately it sounds like you’re going to have to upgrade the OS or find another box that is running one that is a little more current. While it isn’t as nice as Openfire was it 10.3 or 10.4 when Apple started bundling a Jabber server with OSX Server?

Thanks,

Ryan