powered by Jive Software

Online users cannot receive messages until he reconnect

I have a strange situation that Online users cannot receive messages until he reconnect:

User A online

User B online

A sent to B a message ==> Message delivered to B

B replay to A ====> Message never arrived until A Disconnect and connect a gain , all messages form B arrived at once.

I’m also using the monitor plugin to trace the problem, it shows that messages from B, arrived to server once it sent.

Notice: I’m using the latest version of openfire , the client is xabber for android.

Please help me to solve this situation.

This is some issue with Xabber when using with the latest Openfire version Can’t send second message using Openfire 4.0 server · Issue #618 · redsolution/xabber-android · GitHub

1 Like

Dear wrooot ,thanks for responding

The problem you point to, it seems as is my problem.

I used ChatSecure with xabber, the same problem still. also earlier versions of xabber still have the same problem.

So now what is the solution for that problem ? is it downgrade openfire? Does it affect any security or performance issues.

Is there any clients doesnt have this peoblem for android ?

Is it cash or puffer problem that i can change from server ?

I was suspicious of java version, it’s 1.8.0_74, Does is affecting ?

Please help

There were security and performance updates since Openfire 3.10.3 (which is reported as last working fine with Xabber). This is most probably some Xabber bug.

Yaxim works fine on Android with Openfire, but it hasn’t been updated for a long time and doesn’t support group chats. Everyone seems to be glad using Conversations client for Android. But it is a paid one (although there is a way to compile it yourself free of charge).

Reverting to openfire 3.10.3 solves the problem, thank you dear wrooot.

There is anew problem appeared, now i cant login with my last password for admin. tried to put setup to false and add to openfire.xml:

admin

I’m using hsqldb

This let me enter for one time, after restarting openfire i couldn’t do that again.

Any ideas for help?

What OS, Windows? If you have it installed in Program files and run it with a launcher, then you have to run it with “Run as admin” for it to be able to save changes (UAC). You can also try adding some other user as admin (which you know the password of).

No dear, it’s CentOS 6.5

As i said, you can add some other user (which you know password for) as admin. Login with that user, change password for ‘admin’ user. Then login with admin and remove administrator rights from that first user.

I have the same issue. Some investigation shows that the reason is a bug in Xabber. I’ve commited a detailed report on xabber issue tracker:

Xabber ignores capital letters in resource identifier on replies · Issue #665 · redsolution/xabber-android · GitHub

To bypass this bug you cans specify Resource e.g. “android123” (any string but only lower-case letters) in Xabber’s account settings.

1 Like

Hi Alexander,

I don’t have any problem with capital letter my resource name is Android still i can get each and every message.

When i was trying to send muc message i got this type of error so at that time i had some research and found that my servicediscovery manager run after my connection has been established so try to execute service discovey manager before you establish connection. Hope you got solution .