Open Archive + Openfire on Windows = non-threaded logs

I changed my settings to match those sent by SRT and it mad no difference. The dialogs are still disjointed. Does the message audit policy need to be enabled? There is definitely something different.

Can you check the server properties page in the openfire console and check that only “archive.enabled” is set (and no other properties)? Restart openfire afterwards or at least reload the plugin.

Another idea might be to try to increase the 30 minutes to something far higer (like 10000).

Edit: No the message audit policy does not have to be enabled, open archive does not make use of it.

In the properties I now see:

archive.enabled - true

archive.conversationtimeout - 1000

The server was rebooted, and still no change.

What about this post from earlier in the thread:

When SELECTing the conersation elements to be displayed from the archive when searching, it looks like the program SELECTs them by CONVERSATIONID which changes depending on the direction of the conversation. Therefore only half of the conversation is visible. If the CONVERSATIONID remained the same for the conversation then this wouldn’t be a problem.

I have manually changed the values in the SQL db to reflect what should be happening i.e. the CONVERSATIONID remaining the same, and it all works splendidly.

Can anyone see in the code why the program changes the CONVERSTIONID even for the same converation?

The window title for your 2 screens are:

Openfire ???login.title???: Search Archive and Openfire ???login.title???: Archive Settings

I also can not rebuild the index, or type names in the serch fields with out getting an basic error window. The plugin was renamed before installing. I attached a pictuer of the error window.

I am having exactly the same problem. I receive an ‘error’ when entering a search field and clicking the rebuild index. Conversations are split and the header for the main page has "Openfire ???login.title??? etc . I think it may have something to do with the version of openfire. I put the latest version on (3.4.5) and then found this plugin to play with so Im not sure if it would work better on an earlier version.

I am not in a position to reinstall with a previous version to test my theory but maybe someone out there is?

Any help appreciated!


RENAME archive.104.jar or whatever the filename is to archive.jar Browse to it under plugins and you should be good to go. That should get rid of all the ???

I had mine named correctly and still got the question marks.

I am having exactly the same problem. I receive an ‘error’ when entering a search field and clicking the rebuild index. Conversations are split and the header for the Archive Search and Search Archive pages have "Openfire ???login.title??? etc . I switched from embedded to mysql to and still have the problem. I’m running on windows 2k.

OK. I figured this out…for my situation at least. I am still getting the ??? in the title of the archive search window, but at least it’s working. The only way I could find to fix it was to completely remove and reinstall it. It worked after that, but only until I started messing around with changing the domain name. It broke again after that. I re-re-installed it again and it’s working fine. I’ll just leave it alone now.

So what actually caused it to break? Changing the server’s domain name?

Can others confirm this?

P.S. Openfire ???login.title??? is a known issue without functional impact.

I am closing this due to the release of the enterprise plugin as open source. This will now be handled by the monitoring plugin.