powered by Jive Software

Open Fire Memory - Cant set openfire-service.vmoptions over 1536m

So Openfire seems to be eating like 99.4% of its memory allocation.

We are running openfire on a server '03 64bit machine that has 16gigs of ram. 64 bit version of Java.

we have the openfire-service.vmoptions file set with values

-Xms1536m

-Xmx1536m

1.5G

I can’t get past this value. I’ve tried setting them to 2048 etc and the service just will not start.

I’ve gone in and set the Java memory parameter itself to 3gigs to give some over head and tried adjusting the options file again to no avail.

Any ideas? I was under the impression that with a 64 bit OS and JRE i could give it as much memory as i want?

On the Admin Console homepage, look and report here as to what it reports for current running JVM.

Whats weird is its saying the OS is x86 but I can guarantee it is not.

Nick,

That’s because its running a 32 bit java. Did you install the openfire with jre? if so, I believe that is bundled JRE is 32bit. Since you have a java x64, you can rename the folder JRE located in the openfire install folder. Restart openfire, and it should pickup your system jre (if your java environment var are set in windows).

Ok. I renamed the jre folder in the Openfire install.

My java install is located here.

C:\Program Files\Java\jre6\bin\javaw.exe

I set the environment variable for

Try to start Openfire and it wont launch.

Same error it throws when I was trying to up the memory.

I removed the variable and ran the java -version command

I don’t mess with java much so not sure what the path should be in the environment variable.

you’ll need to install java 8. if you can’t for whatever reason, than you can download java 8, and copy the jre folder into openfire.

1 Like

ahhhh ok.

Will try that and get back to you.

Appreciate the help!

Java 8 won’t run on server 2003. I tried just tossing it in as the jre folder in the openfire folder and it still crashed.

Looks like an OS upgrade is next. Which is silly because you’d think Java 6 64bit would allow more memory usage! This server needs upgrading anyway, just wansnt high on my list haha

1 Like

hmmm…it looks like java 8 runs on 2003 per your screen shot with the included jre. perhaps the installer won’t run though, which i guess is no surprise as windows xp and 2003 went EOL last year. java 6 and 7 are also EOL

That is odd. Im looking at that now , looks like the bundled version of the jre is 8 maybe? but theirs is 32 bit. just strange that i cant feed it more memory either way. I verified i grabbed the 64bit version 8 and replaced the folder etc. really has me scratching my head over here now haha

So anyone have any more to chime in here?

Tried replacing the jre file with the 64 bit build . Everything i do the thing crashes if i up the memory limit .

Its driving me crazy because the memory use is actually causing the server to bog down enough where the functionality is broken.

I don’t even have that many users on. maybe 75 at a time and its maxed out.

not specific to your precise problem but I can certainly chime here…

WK8 R2 Server - latest Openfire

Using Openfire as Service never starts with more than 256k - despite vmoptions file! Out of Memory problems since last Java update

Starting from the Server Icon takes the 1536 Memory vmOptions

What does this mean?

This means that rebooting the Server won’t work as Openfire crashes on the 256k. The only solution right now is to log in and start it from the Openfire Server Icon - and leave the W2K8 Session running!

I will try this 64-Bit Java file transfer and see what happens.

Certainly setting the Java environment variable and renaming the Openfire jre folder doesn’t work

  • that’s OK. I’m an idiot. I goddit now - after making the openfire-service.options file! duh!

Thanks for reading

  • anyways i still would like to try copying the 64-Bit Java files to the Openfire JRE folder. I need to regroup!

ok…i just realized that whats going on…having a “duh” moment.

The installer/wrapper is 32bit, and therefore wont run a 64bit jre. windows or java on windows limits the max heapsize to 1.5gb in 32bit mode.

take a look at this thread.

Openfire 64 bit default installer (w/JRE8-64 bit includes)

right. do they have a 64 bit wrapper? because I even tried some threads that had a 64bit .exe and it didnt work then either.

Openfire on Windows x64 with Java x64

yup i tried that. Didn’t work. I believe its because i cant physically install Java8 on the server 03 and this doesn’t use the bundled folder anymore. I’m currently in the process of upgrading the actual server and will give it all a go when running on server '12

you should be able manually set the environmental variables to get around that issue.

i will give it a go

Essa sua solução resolveu o meu problema! Thaks