powered by Jive Software

Open fire no running

to install openfire in debian, ubuntu, centos, and me the following error occurs in all distibuciones …

I start it and after a few minutes the service stops working just …

use a vps

and if I start the service it works again a few minutes and stops.

if I can help I would appreciate

VPS may have memory limitations. Look in /var/log/messages - the kernel may kill the Openfire process because of extensive memory usage.

try checking if you are running out of memory:

at the terminal:

free -m

this output will show you if you have any memeory avaiable (do this while openfire is running, try repeating it a few times to see fi memory is changing (balooning or something).

Also check to see if you have a swap file setup, as this will help prevent the kernel from forcfully killing your stuff when it’s starving for memory.

the same command of free -m will have a line at the bottom labeled “Swap:”, see if it has numbers in it or if it’s just zero (0). If it’s zero, you dont have swap setup.

Some VPS platforms do not allow swap at all, such as OpenVZ. To my knowledge, many others do such as Xen (XenServer), KVM, etc. However, the OpenVZ VPS’ tend to be the cheapest options (because they are poor in performance and have limitations such as no swap space).

To add swap, follow this guide: http://www.cyberciti.biz/faq/linux-add-a-swap-file-howto/

If your system has less than 2GB’s or memory, i’d say set at least 2GB’s of swap. there’s plenty of discussion on the web for proper swap space size, but start with 2GB’s and see what happens.

thanks for your answers!

currently I have no error log

I have two vps

One with 128RAM and 256 swap

2 with 1GB RAM and 2GB swap

with either presented to me the same error.

I’m mad I can not find the solution

only two users connect to openfire not need much if it’s something with the vps as a machine in my house gives me errors.

if someone wanted my vps via ssh give them access to it!

Thank you!

hmm, ya, 128MB of RAM will probably not work, and 1Gb of ram might be cutting it pretty close, especially after the system has started all it’s services and programs, etc. before you even try to run openfire.

I like these guys for VPS (they use KVM I believe now, but used to be a Xen shop): https://www.ubiquityservers.com/cloud

I had their 2GB plan for a while, but outgrew it once I tried to run anything more than a basic website. So I’m now at the 4GB plan. It’s a very very good price for a VPS that is running on an SSD drive (very very fast!).


Have you tried openfire on one of your 1GB VPS' with the 2GB of swap? I think it should work (maybe not comfortably, but should still run).

thanks for the reply!

use a provider vps follows

http://www.vpscheap.net/linux-unmetered.aspx

if tried openfire on vps with 1GB of ram and I get the same error.

5 or 10 minutes and stops working.

and only connect two users.

and if no user connect just stops.

thanks

I have just installed

apache2

Java

openfire

in some tests MySQL

as to say that the server is saturated

hmm, maybe try setting openfire up on a local computer that has more than 1GB of ram and see if it works. either you are still running into ram/memory issues (depening on what else you have running at the same time) or somet other issue such as file permissoins, or something. my bet is it’s still resources you’re running out of, mainly ram.

you can try this at the terminal:

watch free -m

this will every 2 seconds show you the memory usage. you can try starting openfire, then running the above command, and see if memory usage spikes then crashes when openfire is killed by the system.