Openfire 3.10.0 beta and Openfire Meetings 0.0.9 desktop sharing fails


First of all thanks for all the work with the Openfire Meeting plugin.

I’m trying to get Openfire and Meetings to run and have installed the latest openfire_2015-02-03.deb on a Debian system.

I then set up Openfire and install the Openfire Meetings plugin 0.0.9 from the Admin Console.

Then I’m opening https://domain.xy:1234/ofmeet/?r=123 and can download the chrome extension when I click on share screen.

If I just open ofmeet without a manual room name and open a room with the random words I run into other problems like I won’t be assigned as a moderator and can’t lock the conference or get the invitation link.

I don’t know what’s the problem there.

Using a manual room name and after downloading the extension and reloading the page I click on share screen, select a window to share and then I run into the error:

Unable to switch video stream

The javascript console in chrome shows:

Uncaught TypeError: Cannot read property 'id' of undefined     prezi_player.js?v=2:37
window.PreziPlayer.PreziPlayer.messageReceived                 prezi_player.js?v=2:37

and* *

No conference handler    ofmeet-screenshare.js?v=1:250
newStreamCreated         ofmeet-screenshare.js?v=1:282
(anonymous function)     ofmeet-screenshare.js?v=1:282 (anonymous function)     ofmeet-screenshare.js?v=1:130 (anonymous function)     strophe.jingle.adapter.js?v=3:773

Is that a known problem or did I do something wrong with my installation?

I appreciate your help.

Thank you very much!


I tried an installation of Openfire 3.10.0 beta on Windows Server 2012 R2 and receive exactly the same errors.