Openfire 3.10.2 and OS X Mavericks 10.9.5

I have a completely new and clean install of OS X Mavericks 10.9.5.

I downloaded and installed Openfire’s latest installer, 3.10.2, and installed.

I then went to Terminal and ran ‘java -version’ to initiate a download of Apple’s Java 6 and installed that.

Once Java was installed I attempted to start the Openfire Server from the System Preferences Panel, but it only replied: Could not start the Openfire Server!

I’ve since installed Oracle’s Java 7 SDK, set my JAVA_HOME for the admin user as well as the su, bash, and zsh shells for the root user.

Tried that, it didn’t work.

Did the same with Oracle’s Java 8 SDK, also didn’t work.

The frustrating thing is that the server will startup manually:



sudo /usr/local/openfire/bin/

But it refuses to startup from the System Preferences Panel and will not start Openfire when the system starts.

What command is the panel actually trying to run that is giving me this response in launch.stderr:

Exception in thread “main” java.lang.UnsupportedClassVersionError: org/jivesoftware/openfire/starter/ServerStarter : Unsupported major.minor version 51.0

    at java.lang.ClassLoader.defineClass1(Native Method)

    at java.lang.ClassLoader.defineClassCond(

    at java.lang.ClassLoader.defineClass(





    at Method)


    at java.lang.ClassLoader.loadClass(

    at sun.misc.Launcher$AppClassLoader.loadClass(

    at java.lang.ClassLoader.loadClass(

I can get to manually launch using Java 6, 7, and 8, but it just won’t launch using the panel!

I’ve also rebooted about 100 times and have tried reinstalling the Openfire pkg about a dozen times after trying various changes.