Openfire 3.10 Jan 8th 2014 + Ofmeet 0.0.7 Could Not Start

Hi All,

I need your help with this one, as per subject I have freshly installed Openfire 3.10 from Jan 8th nightly build on Centos 7 added plugin ofmeet.jar 0.0.7 and got the Meetings tab to appear however when I point my browser to https://my.domain:7443/ofmeet I got “Not Found” error. Upon examining the log, I found this error “2015.01.09 15:53:59 org.jivesoftware.openfire.plugin.ofmeet.OfMeetPlugin - Could NOT start open fire meetings” and nothing else. I’m stuck, any pointer would be much appreciated. Thank you

stop and restart openfire

Hi Dele, thanks for replying, I’ve tried restarting openfire, tried restarting the plugin and the server as well but same result. Should I tried different Openfire build? If so which you recomend?

Look more closely at your log files. The answer is always in there somewhere. Also check the chrome console log as well.

I’ll read log again on monday, thanks for your help

Finally I got it working, we’re using LDAP for user population and turns out that ofmeet requires user "" on the roster and added to the conference administrator. Also don’t forget to edit org.jitsi.videobridge.ofmeet.focus.user.password on openfire system properties to match the you have set up on your ldap. One more thing, I haven’t research this thoroughly but I’ve had problems with openfire15th January 2015 build can’t get the other participant video to show up, not sure what’s going on. Hope this helps.

1 Like

Thanks for your feedback. I am getting multiple reports on something broken with latest version of ofmeet (0.0.7) . Still trying to work out if the issue is with dev/stable Chrome, Openfire or the plugin itself. Expect a version 0.0.8 soon…

I can happily report that our ofmeet 0.0.7 works nicely with the jan 8th Openfire.

I appreciate I need to write up some form of a user guide or tutorial, but the jitsi code is constantly changing and I have not implemented all the features from the jitsi-videobridge plugin. Hopefully, the code will become stable and it might get done before openfire 3.10 gets released

1 Like

Thanks for the feedback. Could you also kindly confirm if all chrome versions were latest dev or stable channels or mixed.


I’ve been trying to set up the Ofmeet plugin (0.0.7) with Openfire 3.10 on Windows Server 2008, with MySQL and ActiveDirectory for days… I’ll try the “deniel” recommendation next monday:

  • create user: focus@
  • set property: org.jitsi.videobridge.ofmeet.focus.user.password
  • configure the focus user as “conference admin” (I still don’t know where to do this).

My purpose it to provide a infrastructure to chat (text and voice) with an installable client, with presence control (see online/offline users). I think this can be achieved with OF 3.10 / ofmeet plugin (0.0.7) and Spak client (with the ofmeet-plugin for spark). Am I right?

Thank for the good work!

My desktop’s chrome is at Version 39.0.2171.95 m

My phone’s chrome is at 39.02171.93

The conference admin is under Group Chat - Group Chat Settings - Conference - Administrators

Thank you That confirms my current problem is with latest chrome dev version (41.0)

OK, perfect. So, to put the ideas togheter and make it easier for other users:

To configure Ofmeet 0.0.7 plugin with Openfire 3.10:

  • Create user: focus@ (local user or in the user backend, LDAP/AD).
  • Set the following system property via Web Admin Console (Server -> Server Manager -> System Properties), and value the password of the user focus@: org.jitsi.videobridge.ofmeet.focus.user.password
  • Configure the focus user as “conference admin” via Web Admin Console (Group Chat -> Group Chat Settings -> Administrators).


1 Like

Yes, just to remind that this ONLY needed when the user backend is read only. That includes LDAP (ActiveDirectory) or custom provided. Otherwise plugin checks and does this automatically when it gets loaded.

Thanks for doing this

1 Like

How can I get January 8 nightly build?

where can I find this versions?


You can find all the versions/artifacts at Build Dashboard - Atlassian Bamboo

My Backend is read-only AD. Tested and worked!

1 Like