powered by Jive Software

Openfire 3.3.0 cannot serve when there are up to 924 user connections!

Please help me to solve problem about Openfire 3.3.0 that is not able to serve when the connection is up to 924.

(IM Client-pandion2.5 and spark cannot logon the system inform that you put wrong password or your account is not on the system.) In addition, the admin console is not able to login.

My Environment is Linux Red Hat Enterprise with 4 GB RAM. I using java bundle with openfire3.3.0.

When Openfire is not to serve, the admin console show that java memory is about 13.4%. I set java

hive size on openfire shell scrip with INSTALL4J_ADD_VM_PARAMS="-Xms512m Xmx2688m"

the below is the error on hs_err_pidxx.log

  1. An unexpected error has been detected by Java Runtime Environment:

  1. SIGSEGV (0xb) at pc=0x00029000, pid=3789, tid=88943536

  1. Java VM: Java HotSpot™ Server VM (1.6.0-b105 mixed mode)

  2. Problematic frame:

  3. C 0x00029000

  1. If you would like to submit a bug report, please visit:

  2. http://java.sun.com/webapps/bugreport/crash.jsp


T H R E A D


Current thread (0x05b53000): JavaThread “pool-13-thread-1”

siginfo:si_signo=11, si_errno=0, si_code=2, si_addr=0x00029000

Registers:

EAX=0x00000000, EBX=0x00000000, ECX=0x00000000, EDX=0x70800003

ESP=0x054d0d78, EBP=0x054d0da8, ESI=0x054d0d7c, EDI=0x0aab610c

EIP=0x00029000, CR2=0x00029000, EFLAGS=0x00010246

Top of Stack: (sp=0x054d0d78)

0x054d0d78: b4f34d67 a27af398 00000000 00000000

0x054d0d88: 054d0d88 083deff7 054d0dc0 083df828

0x054d0d98: 0aab610c 083df010 054d0d7c 054d0db4

0x054d0da8: 054d0de4 b4f34ecd a27af398 00000000

0x054d0db8: 00000000 00000000 00000000 054d0dc4

0x054d0dc8: 083df482 054d0e04 083df828 099b534c

0x054d0dd8: 083df4b8 054d0db4 054d0e00 054d0e2c

0x054d0de8: b4f34ecd 00000000 00000000 00000000

Instructions: (pc=0x00029000)

0x00028ff0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

0x00029000:

Stack: [0x05482000,0x054d3000), sp=0x054d0d78, free space=315k

Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)

C 0x00029000

j sun.misc.JarIndex.read(Ljava/io/InputStream;)V+102

j sun.misc.JarIndex.<init>(Ljava/io/InputStream;)V+6

j sun.misc.JarIndex.getJarIndex(Ljava/util/jar/JarFile;Lsun/misc/MetaIndex;)Lsun/ misc/JarIndex;+37

j sun.misc.URLClassPath$JarLoader$1.run()Ljava/lang/Object;+80

v ~StubRoutines::call_stub

V http://libjvm.so+0x2b521d

V http://libjvm.so+0x43d9a8

V http://libjvm.so+0x2b50b0

V http://libjvm.so+0x30af2b

C http://libjava.so+0xaa0d Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedExce ptionAction_2+0x3d

J java.security.AccessController.doPrivileged

In addition i would like to know where can I set java hive size memory on openfire3.3.1

Best Regards,

rapon

Message was edited by: rapon

This sounds like a /etc/security/limits.conf issue for max file handles. Have you tried increasing that setting if the server is running as a non-root account?

Re memory: You can set something like this:

OPENFIRE_OPTS="-Xms256m -Xmx512m"

in /etc/sysconfig/openfire

HTH,

daryl

Thank you your help, _However I have still got the same problem (busy at 943 users connection with 412.51 MB

of 2588.5 MB Java Memory)._

I have upgraded to openfire3.1.1 on Linux Read Hat Enterprise 4 with 4 GB RAM and set

-Xms512m -Xmx2688m using MySql 5.0.37 Community the database cction setting

minimum 5, maximum 50.

The etc/security/limits.conf

  •         -       maxlogins          6000
    

user_a - maxlogins 6000

user_b - maxlogins 6000

@jive - maxlogins 6000

  1. End of file

I’'m not sure about the setting limits.conf is correct or not. Do I have to setup more setting on linux

or openfire.

In addition, I try to use openfire3.3.1 on windows 2003 server with RAM 4 GB. I can setup java size -Xmx 1624MB If I set more than this the sevice is not able to start.

For the Utilize openfire3.3.1 on windows2003 server, the openfire serve on 250 users connection with 55.2%

of Java hive size memory ( 861.69 MB of 1560.00 MB )

Please Help me to solve the problem.

Best Regards,

rapon

hi napon,

I am not sure why you are setting maxlogins in /etc/security/limits.conf, you should set nofile like so:

daemon soft nofile 4096

daemon hard nofile 131072

Where daemon is the user that openfire is running as…

daryl