powered by Jive Software

Openfire 3.3.1 has been released

We are pleased to announce the release of Openfire 3.3.1. This is mainly a bug fixing release with many important fixes. A critical security issue was detected in the admin console so it is highly recommended to upgrade. New RPM installers are provided for RedHat based unixes (RHEL, CentOS, Fedora, etc) so make sure to read the upgrade guide.

Download Openfire from here. The full change log can be found here.

Enjoy,

Openfire Team

how about an upgrade guide using the tar.gz installer?

I don’'t want to wipe out my current setup.

I’'ve just updated using my own unofficial upgrade guide using the tar.gz installer and it worked fine:

  • Move it to /opt/openfire-version
  • Shutdown openfire as user openfire: ./bin/openfire stop
  • Update softlink /opt/openfire to point to the new version

Copy configuration and plugins:

cd /opt/openfire-oldversion
for i in plugins/*.jar
do
  if [ ! -f /opt/openfire/plugins/`basename $i` ]
  then
    cp $i /opt/openfire/plugins/
  fi
done
cp conf/openfire.xml /opt/openfire/conf
cp resources/security/* /opt/openfire/resources/security
  1. Check /opt/openfire/resources/database/upgrade/ for db changes that must be applied
  2. Fix ownership chown -R openfire:openfire /opt/openfire-newversion.
  3. su - openfire
  4. Start openfire: ./bin/openfire start

everything worked using your guide *except *my servername didn’'t transfer. now my servername says 127.0.0.1

any ideas

Message was edited by: jledhead

Thanks so much for the RPM updates And I am excited to see the RHX stuff as well

A small complaint, could OPENFIRE_OPTS please be included in the default /etc/sysconfig/openfire file. I had to poke around a while to figure out how to set Openfire up for more memory. It wasn’'t using

/opt/openfire/bin/openfire.vmoptions

daryl

I added a note to the sysconfig file indicating that you can set _OPTS now. That said, you actually ought to be able to set it right not, even before I did that. It’'s just not documented. =) Give it a whirl and see if it works! Thanks for the feedback!

can anyone help with upgrading using the tar.gz installer?

I was able to upgrade using srt’'s method but my servername in openfire did not transfer to the new install.

help please.

Just go to Server/System Properties and set the xmpp.domain property.

I just downloaded the tar.gz for 3.3.1, and it seems to be the same as 3.3.0. Specifically, the upgrade says that we are now using openfire.sh, but while the /etc/init.d script tries to run openfire.sh, it is not in the tar.gz dist.

What gives?

Hey Daniel,

Where do you see that it is 3.3.0? I just downloaded it and it has 3.3.1 content (e.g. readme and changelog).

– Gato

it bacame so common to get a bunch of exceptions in Launcher window launching for the first time after every upgrade.

java.util.zip.ZipError: jzentry == 0,

jzfile = 196674640,

total = 2830,

name = C:\Program Files\Openfire\lib\openfire.jar,

i = 1620,

message = null

at java.util.zip.ZipFile$2.nextElement(Unknown Source)

at java.util.zip.ZipFile$2.nextElement(Unknown Source)

at java.util.jar.JarFile$1.nextElement(Unknown Source)

at java.util.jar.JarFile$1.nextElement(Unknown Source)

at sun.misc.URLClassPath$JarLoader.validIndex(Unknown Source)

at sun.misc.URLClassPath$JarLoader.getResource(Unknown Source)

at sun.misc.URLClassPath$JarLoader.getResource(Unknown Source)

at sun.misc.URLClassPath.getResource(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClassInternal(Unknown Source)

at org.jivesoftware.openfire.starter.JiveClassLoader.(JiveClassLoader.java:44)

at org.jivesoftware.openfire.starter.ServerStarter.start(ServerStarter.java:88)

at org.jivesoftware.openfire.starter.ServerStarter.main(ServerStarter.java:49)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)