Openfire 3.3.3, Pidgin-2.2.0, "Not Authorized" Issues


I have Openfire 3.3.3 installed. I have created 5 users. Each user can log in to the openfire server fine. I can see all 5 users from the admin console, showing that they are all online.

All users are using Pidgin. I have added all users to have all other users as “buddies”. Each buddy is showing up as “Not Authorized” and the users cannot talk to each other.

I can broadcast a message to all users from the admin console and every user logged in with Pidgin will get this message.

Is there a reason why the users can’t talk to each other? This is a standard openfire configuration, pretty much with all default settings enabled. The same for pidgin.

Suggestions as to how to resolve this are greatly appreciated.

Hi csciguy,

A couple of potential things cross my mind.1) Are your JIDs mixed case? I noticed an issue with Pidgin 2.1.0 on windows where it would get confused about buddy status when mixed case was used. 2) How are you specifying the jabber domain? If you try to add a buddy without the domain name, it will fail.




The id’s are “test1”, “test2”…“test5”.

I add the buddies by specifying something like this "test2@(hostipaddress)/Home.

I’ve also tried test2@(hostipadress) and test2@domainname/Home, as well as test2@domainname.

All give me the “Not Authorized” error.

Can you turn on the debugging window in pidgin before you send the message, and paste the contents of that window when you try? (Im just looking for the xml packets getting sent) They might provide some clue.

What plugins are you running? It sounds as if the clients have not approved the others to chat with them. This can be avoided by using the subscription plugin. I have attached a picture of a sample configuration. There are many plugins that greatly enhance the openfire server and make management easier. I have also attached a picture of all the plugins I am running currently.

I’ve noticed that it had to do with how the buddies were being added in Pidgin. I was adding them as test1, test2, etc, when they needed to be added as test1@mydomain in order to work correctly.

Thanks all.


I had same problem that you had before.

Can you help me how you fix the communicating issue.



I am running OpenFire 3.8.2. I had similar symptoms: pidgin and psi could connect to the server, but peers showed up as offline/server not found.

When I got things to work, specifying buddies using the normal jive URL (e.g., bob@ worked fine.

I believe that the critical steps to getting things to work were:

  • Turning off and deleting the iptables service on the client and server hosts.
  • Sending an authorization request to a peer and having the peer authorize the request.


When you say “Test1@localhost” - do you mean as the username or the host?