Openfire 3.4.2 and IM Gateway 1.2.1 problems?

Since i have upgraded to 3.4.2/1.2.1 i’m constantly having problems with gateways. Most of the time it’s MSN not lighting up. So then i start restarting/relogining Spark and time to time MSn starts to work, or not, or transports icons do not appear at all. Restarting of server is not helping a lot either. Is anyone seeing such behaviour?

That is very strange, i’m not seeing such problems.

So far it’s worked perfect for me.

Well, it works smoothly if everything is ok after server start. I can exit and login again with Spark. But i’m stopping and launching Openfire often per day (this is my test server at home), so time to time such problems appear.

Not much of a help, but I know those issues from older combinations as well. I have no idea what causes them, no errors, nothing. First login, some are missing, second login and everythings fine, login the next day and half of the contacts or/and transports went missing again. Looks to me a bit like a timeout problem (maybe between Openfire and its database?).

They are gone like they came and at the moment it works…haven’t upgraded to 3.4.2 though rubshishands time for some new erro…defiances, I mean >:)

If it helps: I could fix some of the really weird problems with Openfire (like: for half of my users Yahoocontacts where always offline, no errors) by compiling the server by myself not using the bins.

I also have a problem with OF 3.4.2 and IMG 1.2.1. Recently i upgraded OF from 3.3.3 to 3.4.2 and IMG from 1.1.3a to 1.2.1.

First connection worked fine, but next… MSN doesn’t up, ICQ connects but doesn’t show any contacts online. I tried to reconnect about 10 times, it didn’t help.

Have you tried to delete the cache of the server?

Are you using Spark? I had loads of trouble recently between Miranda and Openfire since the update to 3.4 (and still have).

Doublepost. Sorry Didn’t know that Emailreply would take quite a bit to show up.

No i didn’t. I use Miranda.

I’m having problems at least with MSN right now. I can log in, people see me online, but any IMs I send MSN users are never received. This was working before I upgraded to 3.4.2 and IM Gateway 1.2.1.

Is there somewhere I can look to see troubleshooting information?


I just installed 1.2.1a released Dec 11th. Now Openfire will load the plugin but then it bombs out and unloads itself.

Can I get a link to download the previous one that worked?! My server is only @ 3.4.1 and the log is full of

2007.12.12 15:51:12 Ignoring plugin gateway: requires server version 3.4.2

I get the butterfly in Spark but am unable to register with the gateway. I had ver 1.2.0 and it worked ok with 3.4.1

Edit: OK I fixed it by upgrading to 3.4.2 - but just so you know that 1.2.1a doesn’t work on 3.4.1 running on Linux…

I have noticed a few of these “MSN not loading up but people see me online and I can’t see my contacts”.

The same thing happens here - I am running Ubuntu 7.10 with Openfire 3.4.2 + IM 1.2.1a plugin, and we are testing it with the Spark client 2.5.8 on a couple of windows XP machines.

It is actually working very nicely, but we seem to have issues with MSN. What happens is some accounts sign in and some don’t. Openfire reports them as signed in,and you see them as online on msn - but you cannot send messages to them. The only difference between the accounts is that the ones that do sing in have about 10 or so ungrouped contacts in their contacts list,the others that do not sign in have around 100 contacts each.

I have also noticed that even the accounts that do sign in take about a minute or 2 to actually load the contacts. Does anybody have any ideas on why this would happen?

The problem seems to be gone. Closing.

I’m having a similar problem running OF 3.4.5 and IMG 1.2.2a. No matter what transport we use the contacts for those users don’t populate until we log off the transport and log back into it. Very rarely do they show up when logging into spark the first time. I think its a timing/network issue but I can’t track it down.

I am having the same issue with 3.4.5 and 1.2.2a with AIM - i setup gtalk, yahoo and msn and havent had issues with them yet…

After lots of debug log searching I found the connect string that looks like the problem to me… but i’m not sure…

Check out the last line…

After signing into AOL none of the buddies appear, but i look like i am signed in. Then if i sign off and on a few times it will eventually show all the buddies up and seems to work ok after that

008.03.27 08:11:30 Handling AIM-style auth.

2008.03.27 08:11:30

Sending SNAC command: AuthRequest: sn=‘gdepratt78’,

version='ClientVersionInfo: , versionString=‘Apple iChat’,

clientid=12570, major=1, minor=0, point=0, build=388, distCode=198’,


2008.03.27 08:11:30

Setting up SNAC request and listener: AuthRequest: sn=‘gdepratt78’,

version='ClientVersionInfo: , versionString=‘Apple iChat’,

clientid=12570, major=1, minor=0, point=0, build=388, distCode=198’,


2008.03.27 08:11:30 Got auth response!

2008.03.27 08:11:30 Got something else?

2008.03.27 08:11:30 029643 (01/05/00) - Connection #5 tested: OK

2008.03.27 08:11:30 029644 (01/05/00) - Connection #5 tested: OK

2008.03.27 08:11:30 Updating status for TransportSession[gdepratt@openfire]

2008.03.27 08:11:30 aim: Sending packet: <presence to=“gdepratt@openfire” from=“aim.openfire”/>

2008.03.27 08:11:30 OSCAR bos service state change from NOT_CONNECTED to INITING Reason: null

2008.03.27 08:11:30 OSCAR connection to

2008.03.27 08:11:30 OSCAR login service state change from CONNECTED to NOT_CONNECTED

2008.03.27 08:11:30 OSCAR bos service state change from INITING to RESOLVING Reason: null

2008.03.27 08:11:30 OSCAR bos service state change from RESOLVING to CONNECTING Reason: null

2008.03.27 08:11:30 OSCAR bos service state change from CONNECTING to CONNECTED Reason: null

2008.03.27 08:11:30

OSCAR flap packet received: FlapPacketEvent:

flapProcessor=FlapProcessor: seqNum=SeqNum: min=0, max=65535,

last(current)=0, flapCommand=LoginFlapCmd: version=1, cookie=null,

flapPacket=FlapPacket (channel=1, seq=51855)

  •           2008.03.27 08:11:30 OSCAR bos service state change from CONNECTED to NOT_CONNECTED Reason: Connection reset*

I have no clue on how to fix this and its becoming an annoyance with all our users that have external gateways. I’m hoping OF 3.5.0 helps to resolve this.

In my case I found the problem to be our redundant internet connections was causing the problem. It was doing a round robin on our external IP’s and the AIM server didn’t like this and would drop the connections.