powered by Jive Software

Openfire 3.4.5 installer identifies as Wildfire 3.2.2

Hello,

I’m experiencing some server trouble today and one of it was Openfire 3.3.3 not working anymore. So I decided to finally do an upgrade now. This is a Debian 3.1 machine. I first upgraded Java from 1.6.0.0 to 1.6.0.5, then downloaded and unpacked the Openfire 3.4.5 archive. I restored my previous conf/openfire.xml file and tried to start the daemon, but it didn’t work. The process was running but nothing else worked. So stopped it again, tried the original factory configuration, but nothing changed.

Then I deleted the entire /usr/local/openfire directory, unpacked and chown’ed it all again. This time with the original config file. The web interface on port 9090 now responded, but it shows me a login mask from Wildfire 3.2.2! What the hell is that? I checked all path names and started the Openfire deamon manually but it’s still the same.

Where’s the installer? Why does it say it’s version 3.2.2?! The changelog.html file counts up to 3.4.5, so I definitely got the right files.

Can somebody help me (again) with installing Openfire, please? Somehow it never works like it should. This is why I usually do not upgrade Openfire unless it is absolutely necessary.

Okay, the problem seems to be another process. The ports were still used by an unknown “java” process. I don’t know where that should have come from because it must have been Openfire 3.3.3 that was identifying as 3.2.2 then.

Now I see Openfire 3.4.5, but the logo upon the login form still ready “Wildfire”. Somebody must have forgotten to upgrade it some time ago when the programme was renamed.

Try holding “shift” when you do a refresh… might have some old files still in the browser cache… I had to do that when configuring the 3.5 RC for testing.