Openfire 3.5.0 Admin Console Menu overlayed in FireFox

I just updated Openfire from 3.4.5 to 3.5.0. I didn’t have this problem with 3.4.5.

The left side menus are overlayed when viewed in FireFox I’ve tested it running FireFox on WindowsXP, Windows Vista, and Windows Server 2003 R2 Datacenter Edition SP1. All show the same problem.

By that i mean I see System Properties overlaying the link to Server. Makes administration diffucult. Screen shot attached.

Message was edited by: jcamden

this doesn’t happen to me in vista and xp using firefox. have you tried a ctrl-f5 in firefox since I believe css stylesheets were changed a good deal to 3.5

with firefox goto tools then options,advanced,network clear cache that should fix any problems

Hey jcamden,

As it was correctly said before, your browser is caching the content of a previous Openfire. Try following the mentioned methods to refresh your browser. The admin console is now orange based (no more blues).


– Gato

Also a simple “shift reload” will do the trick. =)

Gotta love CSS…

Let me start out with “Duh!”. My bad.

Thanks for the replys. I had already cleared the cache in FireFox. I even tried it from a PC that had never been used for the System Admin.

What I didn’t do was follow instructions very well. Especially in the update from .zip were it said to copy the /plugins/ folder from the backup “except for _plugins/admin”.

So what I had was the original 3.4.5 admin plugin in 3.5.0. Any way, all better now. Thanks again.

I can’t decide if it’s worse in IE7 vs. FF3 b5.

IE7 seems to be closer to the desired result. I have definitely cleared my cache (and even disabled it) and still receive apparently mangled CSS. Any ideas?


is that a new install or and upgrade from 3.4.5 if its is do a downgrade back to 3.4.5 and do a new install of openfire 3.5.0 into a new data base then with firefox clean you browser session catch when switch from one server to the other

This is an upgrade from 3.4.5 to 3.5.0. I followed the upgrade instructions outlined here. So, what are the caveats if I nuke the openfire directory and extract 3.5.0 archive into its place? I would obviously need to copy the conf directory over from a backup (as well as the SSL certificates), but is there anything else I would need to do or should be aware of? In the current state, the IM Gateway plugin isn’t operable, even after nuking and reinstalling it.

A shift-reload =ought= to do it. I don’t know why it’s not reloading the css files for you. =/ Browsers are dumb. =D I did used to have a problem with one version of firebox where it wouldn’t load new versions of images until I went directly to them, so try going to:

http://localhost:9090/style/global.css and then do a shift-reload of THAT. Repeat for login.css. You shouldn’t need to mess with setup.css but you might want to do it just in case. ldap.css may have changed too. I don’t recall. Anyway, try that and see if it’ll cache the proper version.

As for installing fresh, as long as your database is intact (if you are using embedded, make sure to copy it away) and your conf file can be restored, you should be fine. Even if you lost your conf file, if you just run through setup and point at the same database, almost all of it will be restored to normal. Of course you’ll need to redownload plugins and such.

Honestly, I’d be surprised if reinstalling will clear your browser cache issue. But if you want to give it a whirl, go for it.

Ugh – I just realized that I copied plugins/admin over from the backup. So, I have purged it an copied the current directory into its place. Now, it’s a hit more miss kind of thing. Quite often the admin console will fail to display its content and instead throw the following error:

Java heap space
RequestURI=/index.jsp Caused by:
java.lang.OutOfMemoryError: Java heap space Powered by Jetty://

Have the minimum requirements increased with 3.5.0?

Not as far as we’re aware. =) I’ve been running it on pretty piddly hardware with pretty piddly memory settings.

I have been running ours in an Ubuntu 6.06LTS virtual machine with 256MBs of the host’s memory allocated for RAM. It’ been flawless up until now. Do you think that increasing the guest’s memory to 384 or 512MBs will solve this issue?