Openfire 3.5.0

Hello everyone I have tried to upgrade the openfire 3.4.5 to the 3.5.0 but upgrade did not work.So I did a new install and everything whent very well.Ihave all the plugins install and working grate I have the red5v0.1.3 installed and working grate jwchat working.

But when I try to improt my clients data I keep getting the message the schema dos not match and wont import.Like to know if the new user database is that much different.

Like the new openfire3.5.0 its very nice cant wate to test drive as my public server


Where are you seeing that the schema does not match? What specific messages are you seeing?

when I try to import the user.xml data from the from the openfie 3.4.5 to the rc2 that message apears!but is ok I am going to make every one reregister the user names anywhay tha way I can clean out all the inactive users at same time.I will be doing my first test run today keeping te old server as back server.If all gose well I will keep it running as the publice server.Like the new admin its very nice.and I got such a good install on the new install I think everything will very for user data

they must have made some changes making the old and new different


Where are you using this user.xml? UserImportExport plugin? =) Not that it looks like it’s going to be entirely useful to you at this point, but I would like to know what’s going on if I can do something about it pre-release! =)

Yes that right import export plugin is where I get the schema message I have used this plugin many times before.It has been very usful this is the first time that has happend.the My SQL database would not upgrade from one to another so I did the openfire 3.5.0 as a new install in a differentt directory witch went very well! As for export improt user the was no error messages that I could fined just a very short message the shema whas different and could not be imported so there was not much info to go sorry it could not be info to help.I like the new server it is very nice .my system imfo is wnxp duel channel duplex lan amd xp duplex channel core just so you have all the info that I have


Minor bug. Just got to the end of an install, verifying everything as we go, I got:



Caused by:

     at org.jivesoftware.openfire.admin.setup.setup_002dfinished_jsp._jspService(
     at org.apache.jasper.runtime.HttpJspBase.service(
     at javax.servlet.http.HttpServlet.service(
     at org.mortbay.jetty.servlet.ServletHolder.handle(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.util.LocaleFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.admin.PluginFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler.handle(
     at org.mortbay.jetty.servlet.SessionHandler.handle(
     at org.mortbay.jetty.handler.ContextHandler.handle(
     at org.mortbay.jetty.webapp.WebAppContext.handle(
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerWrapper.handle(
     at org.mortbay.jetty.Server.handle(
     at org.mortbay.jetty.HttpConnection.handleRequest(
     at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(
     at org.mortbay.jetty.HttpParser.parseNext(
     at org.mortbay.jetty.HttpParser.parseAvailable(
     at org.mortbay.jetty.HttpConnection.handle(
     at org.mortbay.thread.BoundedThreadPool$

*Powered by Jetty://*

Trying to connect again to :9090, resulted in the setup process repeating, however, the configuration was stored, and restarting the applicaiton allowed me to login.

Also, after getting into the admin console, the text layout appears to be broken (see attached).

Browser Firefox ,Ubuntu Gutsy

Im guessing this was developed aginst IEx, looks great on IE7.

Check out my blog post Do a shift reload, that’ll fix the layout. CSS changed but browsers are stupid. =)

And of course it wasn’t developed in IE7 =P Primarily Firefox. IE6 ended up making me have to bend over backwards to fix it’s stupidities. =/

I can’t reproduce the end of setup error. Hrm. Were you setting up LDAP? None-LDAP? Clearspace integration?

oh yea, thats better. Stupid web browser!

LDAP server is active directory, non SSL connected. I verified all stages where given the opportunity:

  1. DB verified - once I fixed the ‘select 1’ thing for proper DB2 table names,

  2. LDAP User lookup verified, including custom decrapify filter

  3. LDAP Group lookup verified, including custom decrapify filter

It just barfed on the last page, worked fine after a restart.

javahollic wrote:

LDAP server is active directory, non SSL connected. I verified all stages where given the opportunity:

  1. DB verified - once I fixed the ‘select 1’ thing for proper DB2 table names,

What? What are the proper table names for DB2?

  1. LDAP User lookup verified, including custom decrapify filter
  1. LDAP Group lookup verified, including custom decrapify filter

It just barfed on the last page, worked fine after a restart.

Huh. Ok thanks!


I have traced down my userdatat import export was due to Aptana studio and I uninstalled it and the import export user data worked perfictly.So I just stop by to drop of that info

Bruce happy camper boy is this a nice thaks from K.I.M CHAT

I saw previous threads for previous versions saying ‘Select 1’ fails on Oracle. Well, add DB2 to the list.

All I did was change the connection validation query from ‘Select 1’ to ‘Select count(*) from OPENFIRE.MUCROOM’, I dont think DB2 likes the select 1.

If the DB setup had allowed me to provide the validation SQL, along with an example (like above!) I wouldnt have to drop back to hand-modifying the XML. Install process feature request!?

Oh wow, thank you for the update! Seems bizarre that Aptana studio would have been causing that! But hey. Not going to argue with success. =D

Good lord. Well, honestly, I wouldn’t recommend doing the query you are doing for the test as it is actually using up some processing time, so to speak. That said, for the moment, whatever works …

As it turns out I just got a DB2 setup installed recently to poke at.

However I’m not “next to it” at the moment. Would you mind trying the following statement to see if it works:


Nope. BTW, DB2-express-C on amd64 linux

2008.04.08 15:41:19 org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConnect DbConnetionProvider: Error while getting connection:

java.sql.SQLException: Created a new connection but it failed its test

at org.logicalcobwebs.proxool.ConnectionPool.getConnection( )

at org.logicalcobwebs.proxool.ProxoolDriver.connect(

Ug. Ok, thanks for testing that! JM-1317

Crap, my DB2 server won’t start up. Would you mind trying the following statement:

select current_timestamp from sysibm.sysdummy1