Openfire 3.5.1


I recently found the source rpm for 3.5.1. I then setup my build environment and did the necessary changes that I wanted. I then built the rpm with rpmbuild command and everything works fine as far as the build goes.


Although my changes are in the following files:



I start up openfire and I get the setup screen all over again. The goal is to have openfire setup once the rpm is installed. I have edited the tags true. I have also taken a look at the for this particular version and added the following property. Already Run

These both fail!

At this point I am not sure what my problem is as far as syntax or just not understanding the properties.

Could someone point me in the right direction!!

Thanks in advance,


p.s. I get the same results for the following tags



One of the cause of repetitive setup is permissions issues. User running the setup and openfire should have write permissions on /openfire/ dir.

Thanks wroot,

That worked! I build the rpm as a regular user but the person who installs the rpm is the root user. So that user needs to have permissions set on the other permissions. Is that the correct summation?



I’m not sure i understand your last question. The user running Openfire should be able to write to /conf/openfire.xml to complete a setup. Also there are some other places in the /openfire/ dir that should be writable. So, personally, i’m doing chown -R on the /openfire dir. If you run Openfire with a regular user (and you should, this is not recommended to run a service with a root user) then you should chown that dir to that user after the installation. I’m not using the installer. So i’m extracting it (tar.gz version) and running it with a regular user without root being involved. I needed root only when i was setting it up for the first time. Because i put my Openfire to /opt/ dir (this is not required, can be your home folder too). Also i had to copy startup deamon to my daemons dir and to add that daemon to my rc.conf, so i needed root permissions for that. But now i dont use root for the Openfire maintenance.