Openfire 3.6.0 Bugs

So far I have found the following issues/bugs:

  • Upgrading from openfire 3.5.2 with Active Directory LDAP, admin users are not transfered to the database correctly. You can not login to the admin page, infact the admin page does not load.
  • To resolve the issue edit the openfire.xml setup tag to read false
  • Client Control plugin no longer works. The client management page is blank. ScreenShot008.jpg

If I’ve already run the setup, will editing this file and re-running setup fix the problem? I didn’t find this post until AFTER I’d upgraded and found that all my admin accounts don’t work.

–Aric

Checkout this thread.

If you are running AD LDAP and have an external database, then yes it worked for me. I edited my openfire.xml after I tried to upgrade. The setup process successfully fixed my issues and upgraded my database.

Anything in the logs regarding the client control plugin? It’s possible I need to do a quick rebuild and release for 3.6.0.

As for the admin console – you upgraded and it wouldn’t load the admin console at all??? Again, anything in the logs? =/

I am sure there are logs. Some where. But it was a matter of AD users that were the admins not coming over correctly. When I re-ran the config for openfire via false it was the only setting that was not correct. There were no admins any longer. I just readded them and all is well.

Actually once changing that line in the xml file, I had to run back through the setup in the admin console. But once that was done I was back up and working.

–Aric

Good to hear.