Openfire 3.6.0: Clearly there are some issues, what is the plan?

Hi folk, clearly you all have helped me identify some serious upgrade issues here and there with 3.6.0. I’ve pulled out some key ones from all of the reports and am going to work on fixing them up real quick. (need to test and see if I can reproduce first) The plan is to release a 3.6.0a ASAP. Not everyone is having issues. Those of you who are not probably won’t need 3.6.0a at all. Please don’t take this as a indication to stop reporting issues. =) You may not be seeing the same things everyone else is and if I don’t know about it to fix it, I probably won’t get it into 3.6.0a. This release won’t be occurring “in an hour or so” because I have a lot to test and evaluate, but stay tuned!

The bulk of the reports so far are around DB script issues with the upgrades, and LDAP not handling usernames with spaces in them. The embedded db seems to be the most prone to issues right now.

Just an update folk — I probably could release tonight but I’m going to give it a night and run some more tests in the morning before releasing — 3.6.1. Turns out our versioning scheme for Openfire doesn’t support 3.6.0a. Anyway, tomorrow I should be putting out an updated release so stay tuned!

Actually, I take that back. I may still release it as 3.6.0a, but in the console itself it’ll show as 3.6.0. Will think about it.

If how you guys name the version was the issue…

Arkymedes wrote:

If how you guys name the version was the issue…

What? I don’t follow.

I guess that was supposed to say:

If only the versioning scheme was the issue we wouldn’t have any problems, but there are some major bugs and nobody cares about the “name” of the bugfix release

(don’t shoot the messenger… a bugfix release would be nice though)

scratch head Who was saying the only issue was the versioning scheme? I was just saying that I can’t release a 3.6.0a that “looks like” a 3.6.0a in the admin console. I’m going to effectively re-release 3.6.0 with the package names of 3.6.0a. Good lord, just trying to keep people in the loop about my thought process instead of keeping quiet here. =P So in summary, versioning comments are for my own benefits. If anyone is going to take offense at them, get over it, ignore them if you want. ;D

As for a status report, I’m currently running through all of the databases and upgrading all the way from the last version of Wildfire to 3.6.0 and making sure upgrades happen correctly. Just found a bug in the db2 scripts from a long long time ago. =/

Besides that, I’m trying to make sure y’all know to either look for 3.6.1 or 3.6.0a =)



To be fair to Daniel, I’ve run several upgrades from 3.5.1 to 3.6.0 with a MySQL 5 backend and it’s worked perfectly every time on my test server which is a ‘mirror’ of the live environment.

Just one point, if I recall, I had an issue with the version 14 script a while ago and I fixed it by manually editing the upgrade script myself (I think it was Daniel who gave me the fix). I wonder if other people had been or are affected by it.

Oh wow, thank you! It’s helpful to my … well mood frankly … to hear successes when they exist. =)

I updated from 3.5.2 with the hybrid user provider compiled from source to the 3.6.0 without a problem

Although I guess I am the only one who does this update, but it worked without a problem! I finally can simply use the rpm and don’t have to recompile with the extra hybrid user provider file

Well, I’m sure that although there are issues out there, it can’t all be doom and gloom. I tried the install on both my existing DB and also an ‘empty’ schema which I needed to find out how get other JID’s as authorised admins which I’ve now done.

I also think you’ve done a great job on the features and I’m just having a play around at the moment.

Ok folk! I have completed my db tests and am building the 3.6.0a installers now. It’ll probably be a couple of hours before everything is uploaded and I write my post about what you might need to do if you attempted 3.6.0 before without backing out to a 3.5.2 restore. So… coming real soon. =D

Well, I made the upgrade using the .deb package and my ldap search to build my groups failed. Tried to put back the confs on the openfire.xml file but then openfire wouldn’t start.

Cleaned my db, purged my old installation and tried from the scratch to test again. I will let you now tomorrow morning if got better.

Uhm, you realize I haven’t released the fixed version yet, right? =) It’s coming in a few hours.


I sent you an email from my gmail this time about breakage of Postgresql < 8 with one of your fixes today. Hope you get this in time…


I did, thanks! I hate databases.

Oh Yes, but I just came to look for problems on the project page after the upgrade gone wrong. I made minor changes in the search scope of my LDAP and is working fine. Now I’m going to wait to upgrade to 3.6.0a because I left my users with no chat almost two hours. My best regards.

=) always make a backup of your setup so you can revert to it asap if there are problems!!! =)