powered by Jive Software

Openfire 3.6.4 memory full

Hello,

i have Openfire 3.6.4 installed on Debian Lenny 5.0 VPS. I’m using following configuration:

Java Version:
1.6.0_12 Sun Microsystems Inc. – Java HotSpot™ 64-Bit Server VM
Appserver:
jetty-6.1.x
Host Name:
vps1333
OS / Hardware:
Linux / amd64
Locale / Timezone:
en / Central European Time (1 GMT)
Java Memory

30.32 MB of 123.75 MB (24.5%) used

I’m using following plugins:

Fastpath Service

Support for managed queued chat requests, such as a support team might use.
4.1.0

Jive Software

Fastpath Webchat

Web based chat client for Fastpath.
4.0.0

Jive Software

Kraken IM Gateway

Provides gateway connectivity to the other public instant messaging networks
1.1.2

Daniel Henninger

Monitoring Service

Monitors conversations and statistics of the server.
1.1.1

Jive Software

Registration

Performs various actions whenever a new user account is created.
1.4.1

Ryan Graham

Subscription

Automatically accepts or rejects subsription requests
1.2.0

Ryan Graham

ser Import Export

Enables import and export of user data
2.2.0

Ryan Graham

My VPS has:

1024MB RAM

5GB Space

I have over 500 Users and there are 50-100 users online at the same time.

The probleme is, that server memory is full after 1-2 days and I have every time to send ticket to my provider, that they restart the server. I can’t access to SSH or Openfire Admin Console.

Is there anyone with the same problem? Or does anyone knows how to fix it?

Thanks!

Hi,

with “-Xmx128m” your Openfire server will likely never use more than 512 MB so I wonder which other products run on your VPS. You could restart Openfire daily anyhow I wonder whether this does help.

LG

~# ps ax

PID TTY STAT TIME COMMAND

1 ? Ss 0:00 init [2]

5677 ? Rs 0:00 sshd: root@pts/0

6137 pts/0 Ss 0:00 -bash

7443 pts/0 R+ 0:00 ps ax

24538 ? Sl 0:00 /usr/sbin/rsyslogd -c3

24547 ? Ss 0:00 /usr/bin/dbus-daemon --system

24554 ? Ss 0:00 avahi-daemon: running [nonepub.local]

24555 ? Ss 0:00 avahi-daemon: chroot helper

24563 ? Ss 0:00 /usr/sbin/sshd

25633 ? S 0:00 /bin/sh /usr/bin/mysqld_safe

25672 ? Sl 0:04 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/m

25674 ? S 0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld

25726 ? Sl 2:08 /usr/lib/jvm/java-6-sun/bin/java -Xms128m -Xmx128m -server -DopenfireHome=/usr/share/openfire -Dop

25752 ? Ss 0:00 /usr/sbin/cron

There nothing special on the VPS. I have fresh installed OS and all what i installed is openfire and MySQL.

Here is my /etc/default/openfire file:

~# cat /etc/default/openfire

Defaults for openfire initscript

sourced by /etc/init.d/openfire

installed at /etc/default/openfire by the maintainer scripts

This is a POSIX shell fragment

Additional options that are passed to the Daemon.

DAEMON_OPTS="-Xms128m -Xmx128m"

~#top

Tasks: 14 total, 1 running, 13 sleeping, 0 stopped, 0 zombie

Cpu(s): 0.1%us, 0.1%sy, 0.0%ni, 99.8%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st

Mem: 1048576k total, 789856k used, 258720k free, 0k buffers

Swap: 0k total, 0k used, 0k free, 0k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND

1 root 15 0 10304 732 612 S 0 0.1 0:00.97 init

5677 root 15 0 70032 3108 2484 S 0 0.3 0:00.02 sshd

6137 root 18 0 17496 1824 1324 S 0 0.2 0:00.01 bash

10234 root 15 0 18812 1084 856 R 0 0.1 0:00.00 top

24538 root 18 0 188m 1408 980 S 0 0.1 0:00.18 rsyslogd

24547 messageb 25 0 21080 884 668 S 0 0.1 0:00.00 dbus-daemon

24554 avahi 25 0 31592 1412 1168 S 0 0.1 0:00.00 avahi-daemon

24555 avahi 25 0 31592 508 292 S 0 0.0 0:00.00 avahi-daemon

24563 root 18 0 48856 1200 704 S 0 0.1 0:00.00 sshd

25633 root 24 0 17308 1452 1160 S 0 0.1 0:00.00 mysqld_safe

25672 mysql 15 0 238m 24m 5480 S 0 2.4 0:04.70 mysqld

25674 root 25 0 3772 580 492 S 0 0.1 0:00.00 logger

25726 openfire 25 0 694m 231m 9.9m S 0 22.6 2:09.19 java

25752 root 20 0 18540 940 724 S 0 0.1 0:00.07 cron

You see, there is nothing special, but java overtakes 694m memory!

~# free

total used free shared buffers cached

Mem: 1048576 789652 258924 0 0 0

-/+ buffers/cache:789652 258924

Swap: 0 0 0

I realy don’t know how to fix it. I have every day to restart the VPS.

whowants

Hi,

you may want to add a swap partition with 1 - 2 GB, this should help a lot.

LG

Hi,

I tried this already. But after some research I noticed, that it’s impossible to add swap into a VPS. It’s blocked.

mkdir /swap

dd if=/dev/zero of=/swap/swapfile bs=1M count=1024

1024+0 records in

1024+0 records out

1073741824 bytes (1.1 GB) copied, 2.02027 s, 531 MB/s

chmod 0600 /swap/swapfile

mkswap /swap/swapfile

Setting up swapspace version 1, size = 1073737 kB

no label, UUID=8d89b70c-2522-4b88-b7eb-08a62fb5ecb6

swapon /swap/swapfile

swapon: /swap/swapfile: Operation not permitted

Any ideas?

Hi,

ask your VPS provider.

You could try to use a 32bit JVM which may be more friendly in allocating virtual memory.

LG

If the problem occurs after a couple of days, there’s a chance that you’re running into a memory leak. Lately, a memory leak related to PEP (a part of Openfire) has caused quite some problems on networks on which at least one user uses the Empathy client.

You’ll find more information and a work-around here: Openfire 3.6.4 memory leak with Empathy