powered by Jive Software

OpenFire 3.7.0 - FastPath WebChat not installing?

Howdy -

I’ve been running Openfire 3.6.4 for over a year with the Fastpath Service (4.1) and Fastpath Webchat (4.0) running flawlessly.

That system is running Windows 2003 with the embedded database

I am going to consolidate systems across the organization and wanted to move Openfire to version 3.7 and use a MSSQL 2008 backend.

I installed the database on a Windows 2008 x64 | MSSQL 2008 system with no trouble.

I installed a clean front-end of the latest version (3.7) on a different Windows 2008 x64 system and again - everything works fine - LDAP integration, etc…

The trouble comes when I attempt to install the Fastpath Webchat plug-in. The Fastpath Service installs fine, but the Webchat plug-in appears to install but never ‘leaves’ the Available Plug-Ins page (but the green + / check do not appear either) and it never appears in the installed plug-ins page either.

I have done a lot of searching but hopefully I am just missing something - I attempted to manually load the .war file found in this post:

http://community.igniterealtime.org/docs/DOC-2156

  • that didn’t work either.

I’ve also tried a different version of plugins_webchat.war and that didn’t work either.

I’m at a loss at this point and sad because I don’t want to remain with my current setup indefinitely.

Thank you for any assistance,

I resolved the error above by verifying my Java install

But - not when I click the Tools link in the Fastpath tab I get this error:

HTTP ERROR 404
Problem accessing /webchat. Reason:

Not Found


Powered by Jetty://

Not sure what the problemo is here - webchat folder exists, start.jsp is in the folder, permissions are granted to the folder.

What about this version? http://community.igniterealtime.org/thread/44193

Thank you very much - I had not seen that thread. I applied the updated webchat.war and see that it displays as version 4.0.2 now - however, now I get:

HTTP ERROR: 503
Problem accessing /webchat. Reason:

Service Unavailable

I assume that the .patch file was informational and that the attached .war file is the compiled version that integrates the patch?

Yep. You should try the war file.

Yeah - I got that far and just the Service Unavailable message now when I click the Tools link.
Shouldn’t be a port or firewall issue since I have not changed anything from the default configuration and I have disabled the firewall to see if that was causing any trouble.

Nothing in the error.log file, but in the warn.log file I see the following:

2011.04.22 14:40:12 Committed before 404 null

2011.04.22 14:40:12 /webchat

at org.eclipse.jetty.server.Response.resetBuffer(Response.java:1047)

at org.eclipse.jetty.server.Response.sendError(Response.java:265)

at org.eclipse.jetty.server.Response.sendError(Response.java:367)

at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpServletResponseWrap per.java:128)

at com.opensymphony.module.sitemesh.filter.PageResponseWrapper.sendError(PageRespo nseWrapper.java:175)

at org.eclipse.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:451)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:530)

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1216)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1187)

at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:425)

at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)

at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:494)

at org.eclipse.jetty.server.session.SessionHandler.handle(SessionHandler.java:182)

at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:93 3)

at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:362)

at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:867 )

at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)

at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandler Collection.java:245)

at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.jav a:126)

at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:113)

at org.eclipse.jetty.server.Server.handle(Server.java:334)

at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:559)

at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete(HttpConne ction.java:992)

at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:541)

at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:203)

at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:406)

at org.eclipse.jetty.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:4 62)

at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:436)

at java.lang.Thread.run(Unknown Source)

This is what ended up working for me

http://community.igniterealtime.org/docs/DOC-2156

Although I think I am still going to deploy the war on a different domain using a tomcat server, as I’ve been having horrible woes with webchat timing out while reaching out to the fastpath plugin.

Maybe you should ask in that thread with the patch and war files.

Or you may try using it with tomcat server as Ninjatek suggests. I think some other users also use it now that way.

That worked for me. I installed that plugin and made sure to change the port setting to 7070 on the server config and I’m up an running. Thanks to wr00t for helping as well.

Nathanc- I am having the same issue you had. I got the webchat to show up with the correct version number in my pluggins, but i am getting a http 503 error when i try and click on tools. What fix in here did you do to get past this. There was a couple suggestions, but i don’t see the true fix?

Any help would be greatly appriciated

The post that Ninjatek pointed me to ended up working (I’ve attached the file to this message as well)

Here is the process I went through (some steps were probably superfluous)

  1. First, I deleted any existing webchat.war files and the webchat folder found in C:\Program Files\Openfire (your file location may be different)

  2. Then, I went to http://www.oracle.com/technetwork/java/javase/downloads/index.html and installed both the Java SE 6 Update JDK and JRE (probably only needed one of those)

  3. With that, I saved the attached webchat.war file to the plugins folder in C:\Program Files\Openfire.

  4. Then, I restarted Openfire and logged into the admin console. You should then see two things happen. 1: in the plugins folder a new folder should appear named webchat. 2. You should now see the Fastpath Webchat Service in the Plugins folder - the version will be 4.0.0 (NOT 4.0.2)

  5. In the Openfire web admin interface, click the Server tab. Select Server Settings > HTTP Binding. In the first section area, select “Enabled - Clients can connect to this server using HTTP binding.” and change the Port from 9090 to 7070. You shouldn’t need to modify the SSL settings. Save Settings.

  6. Click the Fastpath tab and select the Tools link. Likely you will receive an error still. This is because the URL will be http://:9090/webchat - we just changed the port to 7070 though so modify that URL to 7070 (I’ve not attempted to change the link itself since there really isn’t any need to for me) - so, you end up with http://:7070/webchat and you should be all set.

Hope that helps
webchat.war (2232020 Bytes)

Yes, It helped. Got a little futher. Now getting a 404 message instead of a 503.

Been a while since i touched openfire. We don’t have a huge user base that uses it. Pretty much IT and we use the fastpath to offer live chat support. I am guessing it’s something in my settings. Thanks for you help.

Okay - did you change the port setting in Openfire and make sure that you are hitting the correct URL? If so - try restarting the service if you haven’t already.

1 Like

I’m having this same issue. I have tried both WebChat v4.0.0 and 4.0.2. I have double checked that HTTP Binding is set to Port 7070 and to port 70443 for SSL connections.

When I use port 9090/webchat I get Service Unavailable. When I use port 7070/webchat I get Not Found. I’ve tried reinstalling the plugin and restarting the server multiple times.

NathanC- rebooting the server fixed it! Not sure why or how, but it’s working!

Damienball- I did exactly what Nathanc said, and rebooted. So happy to have this back thanks for the help

I suppose the port change isn’t truly committed or implemented until a restart of the service.

Glad you’re back in business - thanks up the chain as well to the folks that helped me.

doing what he said I was able to get it to install. Now I just can’t get anything on the web chat screen.

Hmm…what do you mean “can’t see anything on the web chat screen”?

Is it blank or is there an associated error?

Is this the screen that pops up when you click Tools on the Fastpath tab?

I assume you have created at least one Fastpath workgroup and queue?

It opens to a screen entitled “Fastpath Web Chat” and says “List of available workgroups within Faspath. Click on one of the following workgroups to join.”

It doesn’t show any workgroups. or anything else on the screen. I’ve setup 2 workgroups and queues in each. I can connect both of these queues using the SPark client (2.6.0RC1 on Mac)

Try a couple of things if you can:

  1. Sounds silly but it could just be that the image links aren’t appearing. Try slowly moving your mouse around in the white space (mainly to the left of the page) - you may find that the cursor turns to a hand cursor which you can click.

  2. See the following code - save it as an HTML file and replace any bold underlined value with your appropriate values. If done properly, you should get a simple webpage that has a link named webchat that will open the chat window for you.

Webchat Link Test
    <script language="javascript" type="text/javascript" src="[http://](http://)**servername**:7070/webchat/jivelive.jsp"></script>
<a href="#" onclick="launchWin('framemain','[http://](http://)**servername**:7070/webchat/start.jsp?workgroup=**workgroup_name**@workgroup.**servername**&location=/test.html',500,400); return false;">webchat</a>