Openfire 3.7.0 - Problem with Mac OS X Users

we use openfire extensively as internal instant messaging system (just one server, no server-to-server). for a while now, mac os x users in our network have been reporting problems when chatting with users that use windows or linux:

sometime, messages send by win/linux users won’t get through to os x users (this is with IM-messages, chatrooms work fine). openfire just doesn’t transmit those messages. no errors logged, no acknowledge of this problem, nothing.

we had the same problem with openfire 3.6.4 and updated two months back to see if the problem persists. at first this seemed to have fixed the problems, but now, users have been reporting the same problems again.

almost all of our win/linux users use pidgin as a client. os x users use adium and ichat.

now, what our openfire server DOES log, are a ton of “Packet sent to unreachable address” messages that appear in the info.log file.

2011.11.10 14:52:38 Packet sent to unreachable address

2011.11.10 14:52:38 Packet sent to unreachable address

2011.11.10 14:52:38 Packet sent to unreachable address

those warnings seem to appear everytime a mac-users logs on to the xmpp server and the user given in the “to”-field is always a mac user.

not sure if those warnings are related to our actual problem. just throwing it out there.

May not be worth much, but we experience the same problems. We have 3 Mac users who sometimes fail to recieve messages. Since they all have Win7 VMs our temp. solution has been to launch Spark from there.

bump

What version of Adium are they using? Have you tried a rc/beta build of Adium and checked the debug logs?