Openfire 3.7.0b, problem with log4j using Java wrapper

Hi, I’m trying to get openfire running on a 64 bit JVM on a windows host. In order to instantiate openfire as a service, I am using yajsw to wrap the application, of which I just downloaded the .zip file.

It’s configured and running OK, but log4j fails to initialize due to a missing appender. I’ve tried wildcard adding all the classpath (*.jar) and explicitly defining each .jar file in the classpath but I can’t seem to find anything that makes the message go away. If I run the server directly (openfire.bat) logging functions as expected, but I can’t get service functionality that way.

So the question is, where is org.apache.commons.vfs.impl.DefaultFileReplicator at and how do I satisfiy the appender requirement for it?

Either that, or tell me where the openfire service installer with a 64 bit jvm is at.

Thank you very much for your time.


Here’s the log from the wrapper when starting up:

c:\openfire\wrapper\bat>call setenv.bat
"java" -Xmx30m -jar "c:\openfire\wrapper\bat\/../wrapper.jar" -c "c:\openfire\wrapper\bat\/../conf/wrapper.conf"
Feb 8, 2011 5:52:04 PM org.apache.commons.vfs.VfsLog info
INFO: Using "C:\Users\AARONA~1\AppData\Local\Temp\2\vfs_cache" as temporary files store.
ahessian jmx service bound to port 15002
wrapper|set state IDLE->STARTING
wrapper|starting Process
wrapper|Controller State: UNKNOWN -> WAITING
wrapper|working dir c:\openfire\lib
wrapper|found script scripts/trayMessage.gv
wrapper|started process with pid 2480
wrapper|set state STARTING->RUNNING
Feb 8, 2011 5:52:07 PM ahessian
WARNING: [id: 0x32771eb1, => /] connected
2480/0|log4j:WARN No appenders could be found for logger (org.apache.commons.vfs.impl.DefaultFileReplicator).
2480/0|log4j:WARN Please initialize the log4j system properly.
2480/0|external stop false
2480/0|Controller State: WAITING -> ESTABLISHED
2480/0|Controller State: ESTABLISHED -> LOGGED_ON
2480/0|Openfire 3.7.0 Beta [Feb 8, 2011 5:52:15 PM]
2480/0|Admin console listening at: