OpenFire 3.7.1 no bin?

Hello everyone,

We have used Openfire in thep ast (older versions) and recently rebuilt and moved to Openfire3.7.1.

Since then I am stuck at 256MB ram. I have disabIed PEP(Known memory leak) and still running out of memory.

I am trying to increase my memory to anything higher and I used to use the vmoptions file in the bin directory. Now in 3.7.1 I read and can see there is no more bin directory that is created. If I create one it doesn’t look like it looks to that as its still on 256MB.

The server itself has 3GB of memory and we used to run it around 1536MB.

I am running embedded on Windows, no service.

Is there a System Properties line I can add to increase the memory (much like the PEP false line?)

Any help would be greatly appreciated.



You can set the -Xmx java option - I use -Xmx2048m

Not sure where you set it on a Windows install. FYI, if you use the embedded database you will keep hitting a memory limit as conversations are logged/archived. Running an external database scales much better.

And that’s precisely what I used to put into my openfire(d).vmoptions located in the *bin *folder. But there is no longer a bin folder and anything I create to recreate it is not read by OpenFire any longer on 3.7.1.

Can that option be set directly into the openfire console >server>server manager> server propeties? Does anyone know?

I understand the embedded option isn’t the best, but its all I have for now. It worked great for almost 2 years on the 3.6.x release. There must be a way.

If the value was -Xmx2048m what would the Property name be?

Appreciate the help David.

It’s a JVM run-time option, so it can’t be set through the admin console as a system property.

so I guess my only option is to uninstall and rebuild the server to 3.6.X in order to use the old method?